×
Namespaces

Variants
Actions

Carbide.c++ ЧаВо

From Nokia Developer Wiki
Jump to: navigation, search
Article Metadata

Статья
Перевод:
Оригинал: Carbide.c++ FAQ
Den123
Последнее редактирование: hamishwillee (15 Dec 2011)
----

Contents

Поддержка

Где я могу найти последнюю информацию о известных проблемах и методах их решения для Carbide.c++ ?

Многие известные проблемы и способы их решения описаны в замечаниях к релизу (Release Notes). Их можно найти через меню Help:

Help > Help Contents > Carbide.c++ User Guide > Release Notes

либо

Help > Carbide.c++ Release Notes

в зависимости от версии.

Куда я могу добавить отзыв по работе Carbide.c++ ?

Присылайте все отзывы по адресу feedback.carbide@nokia.com.

Как можно связаться с командой поддержки Carbide.c++ ?

Для того чтобы задать вопросы или сообщить об ошибках используйте сайт поддержки Сarbide на Nokia Developer по адресу http://www.developer.nokia.com/Developer_Programs/.


Построение проекта

Мой проект содержит сотни исходных файлов. При попытке выполнить build, я получаю ошибку компоновщика о том, что командная строка слишком длинная. Как решить эту проблему ?

Помочь должно уменьшение длины путей проекта. Попробуйте переместить папку с проектом как можно выше в иерархии каталогов или просто переименуйте папку проекта и все папки ниже так, чтобы их имена стали короче. Если вы изменили расположение проекта, вам прийдется заново добавить его в ваш workspace с помощью меню

File > Import > Existing Projects Into Workspace.

После перехода от версии Express к Developer/Pro при запуске Carbide я получаю предупреждение "Invalid Project Paths: Include path not found" и мой проект не компилируется.

Убедитесь, что Вы используете другой workspace вместо того, который использовали раньше при работе в версии Express. Вы можете использовать меню

File -> Switch Workspace

для создания нового workspace.

Carbide.c++ v1.1. При попытке использовать в проекте более одной статической библиотеки выдается ошибка компоновщика.

Это известная проблема Carbide.c++ версии 1.1. Для того чтобы добавить более одной статической библиотеки, перейдите в linker preferences вашего проекта и попытайтесь добавить статическую библиотеку в секцию "Libraries" вместо секции "Static Libraries". До тех пор, пока Вы уверенны в указанном расширении .lib все должно работать. (Иначе предполагается расширение .dso)


Настройка Carbide

Я пытаюсь добавить cust kit в окне "SDK Preferences", но там нет кнопки для добавления, есть только кнопка для удаления. Как мне добавить cust kit?

Эта возможность становится доступной благодаря файлу-лицензии, вероятно у Вас с этим файлом что-то не так. Пожалуйста, обратитесь в службу поддержки по адресу license.carbide@nokia.com там Вам помогут решить Ваши проблемы с лицензией.


Отладка

Как я могу отладить запускаемое приложение с одной или несколькими DLL?

В версии 1.1 откройте ваше запускаемое приложение и все необходимые ему DLL-проекты в Carbide.c++. Выберите File > Import > Symbian OS Executable и добавьте каждую DLL в .EXE-проект. При запуске отладки будет загружена вся необходимая отладочная информация, все точки останова в .EXE и .DLL будут использоваться.

В версии 1.2 в параметрах запуска добавилась специальная страница с настройками, благодаря которым все запускаемые в workspace приложения становятся доступными для отладки.

Как я могу увидеть отладочные сообщения, созданные с помощью RDebug:Print в консоли ?

Проверьте настройку "View Process Output" в параметрах отладки. Если эта опция разрешена, отладочные сообщения будут отображаться в консоли "Debug Messages".


Импортирование проектов

Я не могу импортировать ни один проект ! Каждый раз при попытке импорта я получаю множество странных ошибок. Что я делаю не так ?

Убедитесь в наличии свободного места для расширения вашего workspace. Вы можете изменить workspace с помощью меню File > Switch Workspace.


При попытке импортирования mmp файла в Carbide я получаю предупреждение 'CTags not installed or not in path.' Втречалась ли эта проблема раньше ?

CTags - это парсер по умолчанию который используется в Eclipse. Предупреждение выдается в случае, если этот парсер не был установлен предварительно. Если Вы хотите избавиться от этого предупреждения, воспользуйтесь системной помощью и прочитайте информацию об этом предупреждении в замечаниях к релизу (Release Notes). Там же будет представлена ссылка, по которой можно скачать CTags.



Вопросы, связанные с лицензией

Где можно получить ответы на вопросы по проблемам лицензирования ?

Присылайте письмо по адресу license.carbide@nokia.com.

Как я могу получить MAC-адрес своего компьютера ?

Для того чтобы получить Ethernet MAC-адрес своего компьютера под управлением MS Windows:

  • Из меню "Пуск" выберите "Выполнить ..."
  • Введите "cmd" и нажмите "OK"
  • Введите следующую команду и нажмите Enter:
    • ipconfig /all
  • Найдите строку "Физический адрес". Она должна выглядеть примерно следующим образом:
    • Физический адрес. . . . . . . . . : 00-0D-60-FC-64-2F


Как я могу получить идентификатор диска (серийный номер тома) на моем компьютере ?

Для того чтобы получить идентификатор диска на компьютере под управлением MS Windows:

  • Из меню "Пуск" выберите "Выполнить ..."
  • Введите "cmd" и нажмите "OK"
  • Введите следующую команду и нажмите Enter:
    • vol C:
  • Вы должны получить сообщение следующего вида:
    • Серийный номер тома: 2879-77B0


Профилировщик (Исследователь производительности)

Можно ли использовать профилировщик для того чтобы узнать время запуска устройства (Device Startup) и время запуска AppShell ?

На данный момент при использовании версий Developer/Pro это невозможно. Однако, мы работаем над тем, чтобы это можно было сделать в следующих версиях Carbide.


Контроль версий

При использовании плагина Subclipse я получаю ошибку: "Workspace Path Validation Error"

Путь до вашего workspace в Eclipse: c:\Symbian\Carbide\workspace

Однако фактический путь файловой системы: C:\Symbian\Carbide\workspace

Отличие заключается в том, что фактический путь в файловой системе начинается с заглавной буквы. Согласно http://subclipse.tigris.org/faq.html#path-case, это проблема Eclipse 3.1 (и, возможно, более ранних версий) платформы. Очень важно использовать заглавные буквы для обозначения дисков в путях, чтобы этот плагин работал.


Редактор

Почему при нажатии на F3 мне не предлагаются варианты автозаполнения ?

Кликните правой кнопкой мышки на вашем проекте, выберите "Properties" > "C/C++ Indexer"'. Правильным значением для Available Indexers должно быть "Full C/C++ Indexer".


См. также

This page was last modified on 15 December 2011, at 04:28.
78 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×