Namespaces

Variants
Actions

Please note that as of October 24, 2014, the Nokia Developer Wiki will no longer be accepting user contributions, including new entries, edits and comments, as we begin transitioning to our new home, in the Windows Phone Development Wiki. We plan to move over the majority of the existing entries over the next few weeks. Thanks for all your past and future contributions.

Qt Creator 使用技巧

From Wiki
Jump to: navigation, search
Article Metadata

兼容于
平台:
Symbian

文章
flycarl 在 21 Dec 2010 创建
最后由 hamishwillee 在 13 Jun 2012 编辑

Contents

简介

Qt Creator 作为Qt 开发的IDE,支持Qt 开发,及QML开发,能很好的发挥Qt 跨平台的特点,这里列举一些Qt Creator的使用技巧,

代码浏览

在Edit view中很多快捷键,方便你定位到想要的代码。

F4 在头文件和代码之间切换
F2 在声明和实现之间切换
Ctrl + k 打开定位器(locator)
Ctrl + Shift + f 打开全局搜索框
Ctrl + f 打开当前页面搜索框
Ctrl + 鼠标滚轮 缩放代码

定位器(locator)

CreatorLocator.PNG
图:点击Ctrl + k 打开左下角的定位器,命令及功能记录在其中,无需记忆命令

在定位器中输入以下字符加空格,加你想查找的关键字,能在代码中快速定位,试一下。

p 查看当前项目的文件
c 查看类
m 查看方法
l 直接到选中的行号
? 使用帮助中的index

视频演示请看:视频


代码编辑

在Qt Creator 中点菜单栏中Tools->Options->Environment->keybord。

CreatorKeyboard.PNG
图:快捷键设置窗口,可以在Filter栏中输入关键字来定位要使用的功能或特定的键位

这里定义了Qt Creator中的快捷键,组合。可以根据自己的习惯来设定快捷键。合理利用快捷键,会大大提高开发的效率。 参看:高效编辑的七个习惯 ,值得一提的是Qt Creator 内置对Vim的支持,习惯使用Vim的朋友可以选着打开这项功能。 下面列举一些常用功能在Qt Creator的快捷键。

Ctrl + 空格 | 视频]
Ctrl + / 注释或取消注释
Alt + 回车 快速修复,如为头文件中的方法添加实现,或为实现添加头文件中声明,为字符串增加多语言支持等,试一下。
Ctrl + Shift +r 右键菜单’Refactor -> Rename‘,查找替换当前工程的 特定字符,可以使类名或方法名,方便重构操作。
选中几行代码点Tab 几行代码同时缩进。

断点调试

在代码编辑页面,点击行号前可以设置断点,运行Debug进入调试模式。支持方便的联机调试。下图演示运行Qt模拟器时,断点触发的效果。

CreatorDebugBreak.PNG
图:断点调试演示
  • 除了断点调试,还可以使用Qt的 QDebug类,输出Console信息,代码如下
#include <QDebug>
 
qDebug()<<"some";
int count = 5;
qDebug()<<"a number"<<count;
QString str("a string");
qDebug()<<"a QString"<<str;

还可以很方便的使用qDebug获得log: 如何把qDebug输出重定向到一个文件 qDebug在Debug模式和Release模式下都会在Application Output窗口输出(Alt + 3),在各个平台,包括联机调试都可以输出,非常方便。

CreatorQDebug.PNG
图:qDebug的输出

平台管理

在Qt Creator 中点菜单栏中Tools > Options > Qt4

  • 在windows平台下平台配置文件存放在C:\Documents and Settings\<<your Acount>>\Application Data\Nokia\QtCreator.ini
CreatorPlatform.PNG
图:Option中的平台管理页面

项目管理

编译参数(Build)

编译设置界面,设置编译要进行的操作(Ctrl + Shift +B榔头按钮编译全部工程,Ctrl + B编译当前工程)。如下图所示,从上到下

  • 可以通过标签页选择当前工程,
  • 加减号可以增减目标平台种类(图中选中symbian平台),
  • 下拉框可以选择具体的平台及编译Debug或Release版
  • 可以在增加某一种类下的平台
  • Manage 管理平台
  • 平台及工程选择快捷按钮
CreatorBuild.PNG
图:Build设置页面注意图中标记的点用于指定当前的编译平台
  • 为Symbian平台编译生成sis文件,可如下定制命令
CreatorMakeSis.PNG
图:可自定义make sis命令来生成自签名的SIS包
CreatorSign.PNG
图:同样可以通过命令行指定签名证书和密钥
  • 编译时使用证书
CreatorSign.PNG
图:同样可以通过命令行指定签名证书和密钥
  • 生成未签名SIS包
CreatorUnSign.PNG
图:可以通过命令行去掉签名,得到未签名的SIS包

运行参数(Run)

在symbian平台的联机运行设置页面,如下图所示,注意未连接手机,或连接不正常是(连接状态显示红叉)运行不能成功,这时可选择Build页面的命令替代

  • 可以通过选项生成未签名的SIS包(提交symbian签名,或Ovi免费签名服务时需要)
  • 生成自签名的SIS包
  • 设置签名证书和密钥
  • 生成包含smartInstaller的SIS包
  • 部署到手机上并运行程序
CreatorRun.PNG
图:设置在Symbian平台运行前的操作

相关链接

This page was last modified on 13 June 2012, at 10:57.
604 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×