×
Namespaces

Variants
Actions

S60第三版里缺少OpenGL ES 1.1插件的情况

From Nokia Developer Wiki
Jump to: navigation, search
Article Metadata

测试基于
设备:: N93

兼容于
平台: S60 3rd Edition
S60 3rd Edition (initial release)

文章
翻译:
hoolee
最后由 hamishwillee 在 07 Aug 2012 编辑

详细描述

N93上S60第三版的OpenGL ES1.1插件没有包括libgles_cm{000a0000}.dso和libgles_cm{000a0000}.lib文件,但这在编译

OpenGL ES程序时是需要的。

解决方案

要修正手机上出现的这个问题,需要做如下工作:

  1. 到SDK安装所在位置的epoc32\release\armv5\lib\目录,如C:\Symbian\9.1\S60_3rd\Epoc32\release\armv5\lib\目录
  2. 生成libGLES_CM.dso的拷贝,并将其重新命名为libgles_cm{000a0000}.dso
  3. 生成libGLES_CM.lib的拷贝,并将其重新命名为libgles_cm{000a0000}.lib
  4. 重新编译你的程序

这样个问题已经在S60第三版FP1中得以修正了。

This page was last modified on 7 August 2012, at 00:09.
178 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×