×
Namespaces

Variants
Actions

Talk:How to use GCCE 4 with Symbian SDKs

From Nokia Developer Wiki
Jump to: navigation, search
{{{width}}}
02 Oct
2009
Article Review by deepikagohil (20091002)

A good article, which represents a short overview about GCCE(GNU Compiler Collection for Embedded) 4 for Symbian OS, the fundamental requirments about it's installation, the information about it's versions and much more; which can be essential to know before using it.

It provides useful material for beginners to study before getting started.


Seems dont work with S60v5 SDK. Application crashed at startup with Kern-exec. But works on S60v3 SDKs.


CodeSourcery has a new fully-validated toolchain on their site: Symbian ADT Sourcery G++ Lite 4.4-172. It worked for me perfectly with S60v5 SDK

11:23, 28 May 2010 (UTC)


It turns out that with division code it's better to use #ifdef __GCCE__ (tested with Nokia Qt SDK 1.1 and Nokia E72). With just the #if,#if pair the application wouldn't even load.

Jarek

 
×