×
Namespaces

Variants
Actions

Talk:Media Recorder API

From Nokia Developer Wiki
Jump to: navigation, search
{{{width}}}
28 Sep
2009
Article Review by deepikagohil (20090928)

This article provides a brief overview to use Media Recorder API. The soul purpose of this API and how to use it- are clearly described in this article. The article also provides a code snippest which let us understand how to use it. It also provides the guidelines for the same. Apart from that, there is also a link to an example project, which help us to make it more clear.

This article can be useful to developers who intend to use this API in their application.


Contents

GTO India - compiling problem

Please suggest me required libraris and .h files for the API partnering etc.

GTO_India 09:30, 2 July 2012 (EEST)

GTO India - After compiling Iam seeing many errors like Creation Time Description Resource Path Location Type 1341210562828 ccmrmediarecorder.h: No such file or directory mediarecorderapitest.h

ccmrmediarecorderobserver.h: No such file or directory mediarecorderapitest.h


ccmrmediasink.h: No such file or directory mediarecorderapitest.h

`CCMRMediaBuffer' has not been declared dummysink.h


ccmrmediasink.h: No such file or directory mediarecorderapitest.h


`KMMFFourCCCodeAMR' was not declared in this scope mediarecorderapitest.h


similarly there other 70 errors. Please suggest me any other include lib and .h files if any needed. Whether I have to go for API partnering process.

GTO_India 09:49, 2 July 2012 (EEST)

GTO India - where can i find the .h and .lib files like

API is used through these headers: epoc32\include\ccmrmediarecorder.h epoc32\include\ccmrmediarecorderobserver.h epoc32\include\ccmrmediasink.h



Libraries related to this API: epoc32\release\armv5\lib\camcmediarecorder.dso epoc32\release\armv5\lib\camcmediarecorder.lib epoc32\release\armv5\lib\camcmediarecorder{000a0000}.dso

epoc32\release\armv5\lib\camcmediarecorder{000a0000}.lib

GTO_India 12:55, 2 July 2012 (EEST)

GTO India - The API only works on Nokia XXXX starting with firwmare XX.XX.XX On Nokia XXXX, the API is broken, care should be used when calling ...

what do mean by the below instructions:



The API only works on Nokia XXXX starting with firwmare XX.XX.XX

On Nokia XXXX the API is broken, care should be used when calling ...

GTO_India 14:54, 3 July 2012 (EEST)

Hamishwillee - @GTO India - not supported

HI GTO India

This should work on Nokia N80, Nokia N95 using SDK for S60 3rd Edition FP1. It almost certainly won't work on Symbian^3 because the plugins aren't supported on these later versions. You'd need to raise a technical support/API partnering request.

I would raise a separate request on discussion boards describing what you want to achieve - ie at high level. There may be a Qt API to do what you want now.

Regards

Hamish

hamishwillee 09:37, 12 July 2012 (EEST)

 
×