×
Namespaces

Variants
Actions

Talk:SDK API Plug-in

From Nokia Developer Wiki
Jump to: navigation, search

No comment here? Nobody (dis)likes this API package? :)

ltomuta 13:30, 26 February 2008 (EET)


Could we have a short note about how to install it?

I second that. I've got a bunch of zip files - now what? No install docs on the download page or in master zip file. In the zip files inside the zip, there is a README.txt with "Copy this archive to EPOCROOT and unzip." Except that doesn't work. I get a bunch of directories with the API name and underneath that there's an epoc32 directory, which I'm guessing is supposed to be up one level. Can I just manually copy all the files?

Contents

How to solve this problem??

Hi

platform - S60_3rd_FP2_SDK

To do live recording/authoring, S60_3rd_Ed_SDK_FP2_API_Plug-In_Pack_v1_1.zip was unzipped and installed but still are some files which are missing like mmf\mmfcontroller.h, mmf\mmfutilities.h etc etc. These files are required by sounddevice.h which contains CMMFDevsound object which I am using for live audio recording.

Is there any other extension plugin which i need to install to acommplish this task.

Thanks

SyncML missing!

Why is the SyncML Client API not included in "API Plug-in for the S60 3rd Edition SDK for Symbian OS, for C++, supporting Feature Pack 2"?

Thanks, Alex Birkett

MDFDevVideo Record and Playback API

Platform: S60 3rd FP2; Extension : version 1.2; Problem : The corresponding plugin provided by Nokia does not contain the necessary header file epoc32/include/mmf/devvideo/devvideoconstants.h, which is used by other header files in the plugin.


PS Keys for Call Status & Indicators API for S60 3rd MR version

I just updated the article with internal referencing but I feel that it is pointing to wrong link, isn't it? Please click on "History" and see the revisions. --kiran10182 14:13, 2 March 2009 (EET)


missing tvoutengine.lib from 5th Edition Plugin Pack

Hi,

Headers and library of tvoutengine api are missing from the 5th Edition Plugin pack. Is there a way to get the tvoutengine.lib file? I can probably get the header files from eclipse Documentation plugin for this API


The Article informs us about the API plug-ins used in differnt S60 versions. The basic concept of API plug-ins is clearly described and where to use them is also mentioned. The different extension API plug-ins for S60 3rd edition MR , S60 3rd Edition FP1, S60 3rd edition FP2 and S60 5th edition are given in this article. Each API plug-in mentioned is having a link, so that you can get detailed information about that particular plug-in.

The article explains API plug-ins and mentions extention API plug-ins for almost all S60 editions. So it becomes essential for both beginners and experienced people.--deepikagohil 17:25, 6 September 2009 (UTC)



Not able to use Item finder API for 5th Edition Plugin Pack

Hi,

I am not able to use the Item finder APIs, tried sections from "API Plug-in for the S60 5th Edition SDK for Symbian OS, for C++" also. i have open new discussion as http://www.developer.nokia.com/Community/Discussion/showthread.php?179564-CAknItemFinder-not-working-for-S60-5th-Ed&p=642344#post642344. Please rectify and help.

-Jupitar


Really useful article to know how to download SDK Plug-in API that is provided by forum nokia and how to use each API. Since forum nokia is providing API that is not part of the public SDK, we have to download it from link given in this article. The article provides downloadable link for each version of SDK from S60 3rd Edition MR to S60 5th Edition SDK. Also link provided to each API , that is part of API plug-in, will help developer to implement it easily.

--savaj 12:09, 28 September 2009 (UTC)


Problem Installing the SDK Api Plug-in

Hi, I've had soome trouble trying to use the SDK Api Plugin.

Im trying to use QBluetooth - A Qt bluetooth library

wich requires the Bluetooth Engine Api found un the SDK Api Plug-in. When I compile the QBluetooth library I get some, a lot, errors regarding the Bluetooth Engine files been not found.

So I guess I didnt installed em correctly or missed some configuration, I hope u can help me.

As the file inside the zip states Ive copied everything inside EPOC32 folder into the same folder corresponding to my SDK. Im trying to use BluetoothEngineApi, which is designed for S60 3rd edition, so Ive placed the files at C:\S60\devices\S60_3rd_FP2_SDK_v1.1\epoc32

Is there anything else neede to do? I did this and cant use the BluetoothEngine api files.

- OmarGN


Where is qos3gpp.lib?

Hi, I've had some trouble trying to use QoS class.

I am interested in VoIP QoS and found that there is QoS class in "Symbian OS v9.3 » Symbian OS reference » C++ component reference » Networking QOS3GPP » CSubConQosR99ParamSet" , which marked with Location: Qos3GPP_subconparams.h Link against: qos3gpp.lib

But I can not find the qos3gpp.lib? Does someone know how to get it?

Shweta 912 - SW Installer Launcher API

Is there any Plug-in available for Symbian^3?

shweta_912 09:01, 21 July 2011 (EEST)

Paquier -

Where can I find this plug-in for Symbian^3?

paquier 11:22, 11 November 2011 (EET)

Hamishwillee - Shweta 912, Paquier

Where can I find this plug-in for Symbian^3?
There is no specific plugin. We highly recommend you don't use these APIs for Symbian^3 because our update cycle is very fast and there is no guarantee that "unsupported" APIs will continue to work. Instead you should use Qt/Qt Mobility APIs where possible. Where not possible we suggest you use the source from the Symbian PDK (request from http://symbian.nokia.com/ )

hamishwillee 01:26, 18 November 2011 (EET)

Preethi - Phone Client Dial API

Is there any Phone Client Dial API for s60 3rd Edition and s60 5th Edition

preethi 09:06, 6 March 2012 (EET)

Rostgrm - 5th Edition in ZIP format

Is it possible to make a package of ZIPped zip packages for 5th Edition Extension instead of EXE unit? ZIP set is much useful to understand which API is exactly required for proper application building.

rostgrm 11:44, 5 June 2012 (EEST)

GTO India - MediaRecorder API / application

CAN ANY BODY give me the .lib ,.h and .dso etc files used in the mediarecorder application


like


API is used through these headers: epoc32\include\ccmrmediarecorder.h epoc32\include\ccmrmediarecorderobserver.h epoc32\include\ccmrmediasink.h


Libraries related to this API: epoc32\release\armv5\lib\camcmediarecorder.dso epoc32\release\armv5\lib\camcmediarecorder.lib epoc32\release\armv5\lib\camcmediarecorder{000a0000}.dso epoc32\release\armv5\lib\camcmediarecorder{000a0000}.lib


where can I find them or get them ?

GTO_India 15:27, 2 July 2012 (EEST)

GTO India - I found all the libraries and .h files

I got all the required .lib and .h files now but errors like


Creation Time Description Resource Path Location Type 1341232731390 macro "__EMULATOR_IMAGE_HEADER2" passed 10 arguments, but takes just 9 CCMRTest_UID_.cpp /CCMRTest/src line 4 C/C++ Problem 1341232731391 expected constructor, destructor, or type conversion before ';' token CCMRTest_UID_.cpp /CCMRTest/src line 4 C/C++ Problem


still exists.

GTO_India 16:26, 2 July 2012 (EEST)

Rolm - Certificate for Call Adio Control API has expired

The cerificate for the Call Audio Control expired on 2013-04-18. This means that the SISX that hold the API cannot be installed (without adjusting the time on the device). I guess the same issue has hit some of the other APIs as well.

Will there be any new versions provided - signed with newer certificates? Or can this be solved in some other fashion?

rolm 15:54, 15 May 2013 (EEST)

Hamishwillee - Possibly nothing to be done

Hi Rolm

Thanks for posting on the discussion boards - exactly right thing to do. OK to post here because is directly related to above content, but best to also link to Dibo post so that if there is an answer there the readers of this post might get it. Link here.

The problem is that this is for SDKs of devices that are well out of maintenance and that are I believe 4 or 5 years old - with tiny market share. This article really should be archived now, and if the answer is that the SIS files can't be re-signed then I will do so.

I've forwarded the dibo link to the people who might be able to get it re-signed.

Regards

Hamish

hamishwillee 04:01, 16 May 2013 (EEST)

Hamishwillee - Just rolled back removed section (by Posillipo)

This was section for 5th edition. No explanation of why removed.

hamishwillee (talk) 08:38, 6 September 2013 (EEST)

 

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×