×
Namespaces

Variants
Actions

Using Subclipse with Carbide.c++

From Nokia Developer Wiki
Jump to: navigation, search
Article Metadata
Article
Created: tapla (03 Apr 2009)
Last edited: hamishwillee (31 Jul 2012)

Contents

Overview

This article describes how to use Subclipse with Carbide.c++ IDE. Subclipse is an Eclipse plug-in providing support for the Subversion version control system within the Eclipse IDE. Since Carbide.c++ is based on the Eclipse IDE, Subclipse can be used with it as well.

Installing Subclipse

Installing Subclipse is easiest when using Carbide.c++'s built-in software updating functionality. The following steps apply to Carbide.c++ 2.0.0 and Subclipse 1.6.x.

  1. Start Carbide.c++.
  2. Select Help > Software Updates > Find and Install.
  3. Select "Search for new features to install". Click Next.
  4. Add a new update site by clicking on "New Remote Site".
  5. Type "Subclipse" in the name field and the location of the Subclipse update site (e.g., "http://subclipse.tigris.org/update_1.6.x/") to the URL field. The URL can be checked from the Download and Install section of the Subclipse Web site.
  6. Click Finish. The Updater shows the features that are available to install.
  7. Uncheck "Subclipse Integration for Mylyn 3.x (Optional)", because it requires a plug-in that is not installed in Carbide.c++ by default. Click Next.
  8. The Updater asks you to accept the licence agreements. Accept them and click Next.
  9. The Updater asks you to review the features that will be installed. If the install location is correct, click Finish. Downloading begins.
  10. The features to be installed have not been digitally signed, so you may have to dismiss some warnings during the installation.
  11. When the downloading and installation have been completed, restart Carbide.c++, and you're done.

Using Subclipse

Checking out the sources

To check out a source tree, follow these instructions:

  1. In Carbide.c++, select Window > Open Perspective > Other.
  2. Select SVN Repository Exploring. The perspective is opened.
  3. Right-click on the SVN Repositories view and select New > Repository Location.
  4. Type the location of the repository in the URL field and click Finish. The repository appears in the SVN Repositories view.
  5. Right-click on the repository location that you want to check out and select Checkout.
  6. Select the method of checking out the folder and the revision to check out. Click Finish.
  7. The repository is checked out, so you can return to the default perspective: Window > Open Perspective > Other > Carbide C/C++.

Creating a patch

Let's assume you have modified an application and want to describe the modifications as a patch file (see Using Diffs for general information about diffs and patching). One concrete use case for this is that you have modified a stub application and want to create a code snippet from the modifications. This use case is used as an example here.

Note that Subclipse depends on Subversion, so patches cannot be created with it unless the application from which the patch is created has been checked out from an SVN repository. If this is not the case, use the method described in Using Diffs for creating a patch. Here, the application has been checked out from an SVN repository.

The steps for creating a patch are:

  1. (Check out the sources. See above.)
  2. (Modify the sources.)
  3. Right-click on the project and select Team > Create Patch.
  4. Select "Save in File System" and enter a name for the patch file. Click Next.
  5. Select the patch root (most likely the "Project" scope). Click Finish. The patch is created into the location you specified.

Applying a patch

Let's assume you have created an application that you want to patch (see Using Diffs for general information about patching). One concrete use case for this is that you have an unmodified stub application and a code snippet that you would like to incorporate into the stub. This use case is used as an example here:

  1. (Download the stub application.)
  2. (Import the stub into Carbide.c++.)
  3. In Carbide.c++, right-click on the project and select Team > Apply Patch.
  4. Select "File" and browse to the location where the (code snippet) patch can be found. Click Next.
  5. Select "Apply the patch to the selected file, folder or project" and select the (stub) project. Click Next.
  6. In the "Apply Patch" dialog, you can double-click on the file to examine the changes.
  7. Click Finish and the patch is applied to the project.
This page was last modified on 31 July 2012, at 13:01.
50 page views in the last 30 days.
×