×
Namespaces

Variants
Actions
Revision as of 09:36, 15 June 2012 by hamishwillee (Talk | contribs)

Archived:Always allowed setting not available for network access and application autostart in trusted 3rd-party domain MIDlets (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

The article is believed to be still valid for the original topic scope.


Article Metadata
Tested with
Devices(s): Nokia 6680, Nokia 6681, Nokia 6682
Compatibility
Platform(s): S60 2nd Edition, S60 2nd Edition FP1, S60 2nd Edition FP2
Symbian
S60 2nd Edition FP2
S60 2nd Edition FP1
S60 2nd Edition (initial release)
Article
Created: User:Technical writer 1 (21 Apr 2006)
Last edited: hamishwillee (15 Jun 2012)

Contents

Overview

According to the MIDP 2.0 specification's The Recommended Security Policy, trusted 3rd-party domain MIDlet should have an "always allowed" setting for network access and application autostart. However, this setting seems to be missing from some S60 devices, when a MIDlet is signed to trusted 3rd-party domain.

Description

According to the MIDP 2.0 specification's The Recommended Security Policy, trusted 3rd-party domain MIDlets should have "always allowed" setting for network access and application autostart. However, this setting seems to be missing from the Nokia 6680, Nokia 6681, and Nokia 6682 when a MIDlet is signed to trusted 3rd party domain.  

How to reproduce

Install a trusted 3rd-party domain MIDlet to Nokia 668x and try to change the suite setting for network access and application autostart to "always allowed."

Solution

No solution exists. This is fixed in S60 2nd Ed FP3 devices.

125 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×