×
Namespaces

Variants
Actions
Revision as of 09:48, 15 June 2012 by hamishwillee (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Archived:Background noise while streaming zero-filled buffers (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Article Metadata
Compatibility
Platform(s): S60 2nd Edition (initial release) and FP1, FP2, FP3
S60 3rd Edition (initial release) and FP1
S60 3rd Edition FP1
S60 3rd Edition (initial release)
S60 2nd Edition (initial release)
Article
Created: User:Technical writer 1 (21 May 2007)
Last edited: hamishwillee (15 Jun 2012)

Description

In some S60 2nd and 3rd Edition devices the level of background noise may be disturbing when using an audio output stream to play back silence; that is, when the stream is fed with zero-filled buffers.

Solution

Applications should not implement a 'mute' functionality by streaming zero-filled  buffers. Instead, the output stream should either be stopped or its volume level should be set to 0.

Note that adjusting the volume is a significantly faster operation than stopping/restarting the stream.

This page was last modified on 15 June 2012, at 09:48.
108 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×