×
Namespaces

Variants
Actions
(Difference between revisions)

Archived:Binary compatibility break in Text-To-Speech Utility API on S60 3rd Edition (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search
hamishwillee (Talk | contribs)
m (Hamishwillee - Adding missing translation link)
debjit.roy (Talk | contribs)
(Debjit.roy -)
Line 1: Line 1:
[[Category:Known Issue]]
+
[[Category:Known Issue]][[Category:Symbian C++]][[Category:S60 3rd Edition]][[Category:Audio]]
[[Category:Symbian C++]]
+
[[Category:S60 3rd Edition]]
+
[[Category:Audio]]
+
 
__NOTOC__
 
__NOTOC__
 
__NOEDITSECTION__
 
__NOEDITSECTION__
Line 28: Line 25:
 
:This API is not part of the public SDK. It can be found in the [[SDK API Plug-in]].  
 
:This API is not part of the public SDK. It can be found in the [[SDK API Plug-in]].  
 
}}
 
}}
 
+
{{Archived|timestamp=20120313115637|user=roy.debjit| }}
 +
 
 
==Overview==
 
==Overview==
 
TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the [[SDK API Plug-in]] package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.
 
TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the [[SDK API Plug-in]] package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.

Revision as of 14:56, 13 March 2012

Template:KBKI

Article Metadata
Tested with
Devices(s): S60 3rd Edition devices with HQTTS support (Nokia 5500 Sport, Nokia E50, Nokia E65, Nokia N75)
CompatibilityArticle
Keywords: CTtsUtility
Created: User:Technical writer 1 (March 4, 2008, updated October 3, 2008)
Last edited: debjit.roy (13 Mar 2012)


Note.pngNote: :This API is not part of the public SDK. It can be found in the SDK API Plug-in.

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Overview

TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the SDK API Plug-in package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.

Description

TTS Utility provides access to TTS functionality on S60 devices, including the high-quality TTS engine supported in some of the devices.

A list of devices supporting high-quality Text-To-Speech can be found here.

There are binary compatibility breaks between S60 3rd Edition releases for Text-To-Speech Utility and TTS Common APIs. Compiling an application using the TTS Utility API from the Plug-in package and trying to run it on an S60 3rd Edition device will result in KERN-EXEC 3 panic.

Solution

TTS APIs from the API Plug-in package can only be used on S60 3rd Edition, Feature Pack 2 devices.

Versions of the TTS API supporting S60 3rd Edition and S60 3rd Edition, Feature Pack 1 devices of the API can be requested via Nokia Developer API Partnering.

Also note that low-quality TTS can be used via the CMdaAudioPlayerUtility class as well. More information is available here.

88 page views in the last 30 days.
×