×
Namespaces

Variants
Actions
(Difference between revisions)

Archived:Binary compatibility break in Text-To-Speech Utility API on S60 3rd Edition (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search
hamishwillee (Talk | contribs)
m (Bot fixing redirect link)
hamishwillee (Talk | contribs)
 
(11 intermediate revisions by 2 users not shown)
Line 1: Line 1:
[[Category:Known Issue]]
+
{{Archived|timestamp=20120313115637|user=roy.debjit| }}
[[Category:Symbian C++]]
+
[[Category:Known Issue]][[Category:Symbian C++]][[Category:Audio]][[Category:S60 3rd Edition (initial release)]][[Category:S60 3rd Edition FP1]][[Category:S60 3rd Edition FP2]]
[[Category:S60 3rd Edition]]
+
{{Abstract|TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the [[SDK API Plug-in]] package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.}}
[[Category:Audio]]
+
{{ArticleMetaData <!-- v1.2 -->
__NOTOC__
+
|sourcecode= <!-- Link to example source code (e.g. [[Media:The Code Example ZIP.zip]]) -->
__NOEDITSECTION__
+
|installfile= <!-- Link to installation file (e.g. [[Media:The Installation File.sis]]) -->
{{KBKI}}
+
|devices= S60 3rd Edition devices with HQTTS support (Nokia 5500 Sport, Nokia E50, Nokia E65, Nokia N75)
{{KnowledgeBase
+
|sdk= <!-- SDK(s) built and tested against (e.g. [http://linktosdkdownload/ Nokia Qt SDK 1.1]) -->
|id=KIS000843
+
|platform= S60 3rd Edition
|platform=S60 3rd Edition
+
|devicecompatability= <!-- Compatible devices (e.g.: All* (must have GPS) ) -->
|devices=S60 3rd Edition devices with HQTTS support (Nokia 5500 Sport, Nokia E50, Nokia E65, Nokia N75)
+
|dependencies= <!-- Any other/external dependencies e.g.: Google Maps Api v1.0 -->
|category=Symbian C++
+
|signing= <!-- Empty or one of Self-Signed, DevCert, Manufacturer -->
|subcategory=Audio
+
|capabilities= <!-- Capabilities required by the article/code example (e.g. Location, NetworkServices. -->
|creationdate=March 4, 2008, updated October 3, 2008
+
|keywords= CTtsUtility
|keywords=CTtsUtility
+
|language= <!-- Language category code for non-English topics - e.g. Lang-Chinese -->
 +
|translated-by= <!-- [[User:XXXX]] -->
 +
|translated-from-title= <!-- Title only -->
 +
|translated-from-id= <!-- Id of translated revision -->
 +
|review-by= <!-- After re-review: [[User:username]] -->
 +
|review-timestamp= <!-- After re-review: YYYYMMDD -->
 +
|update-by= <!-- After significant update: [[User:username]]-->
 +
|update-timestamp= <!-- After significant update: YYYYMMDD -->
 +
|creationdate= March 4, 2008, updated October 3, 2008
 +
|author= [[User:Technical writer 1]]
 +
<!-- The following are not in current metadata -->
 +
|id= KIS000843
 
}}
 
}}
 
+
{{Note|This API is not part of the public SDK. It can be found in the [[SDK API Plug-in]].}}
 
+
{{NoteS}}
+
:This API is not part of the public SDK. It can be found in the [[SDK API Plug-in]].  
+
{{NoteE}}
+
 
+
==Overview==
+
TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the [[SDK API Plug-in]] package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.
+
  
 
==Description==
 
==Description==
 
TTS Utility provides access to TTS functionality on S60 devices, including the high-quality TTS engine supported in some of the devices.
 
TTS Utility provides access to TTS functionality on S60 devices, including the high-quality TTS engine supported in some of the devices.
  
A list of devices supporting high-quality Text-To-Speech can be found [http://europe.nokia.com/A4286225 here].
+
A list of devices supporting high-quality Text-To-Speech can be found [http://europe.nokia.com/support/product-support/text-to-speech here].
  
There are binary compatibility breaks between S60 3rd Edition releases for Text-To-Speech Utility and TTS Common APIs. Compiling an application using the TTS Utility API from the Plug-in package and trying to run it on an S60 3rd Edition device will result in KERN-EXEC 3 panic.
+
There are binary compatibility breaks between S60 3rd Edition releases for Text-To-Speech Utility and TTS Common APIs. Compiling an application using the TTS Utility API from the Plug-in package and trying to run it on an S60 3rd Edition device will result in KERN-EXEC 3 panic.
  
 
==Solution==
 
==Solution==
 
TTS APIs from the API Plug-in package can only be used on S60 3rd Edition, Feature Pack 2 devices.
 
TTS APIs from the API Plug-in package can only be used on S60 3rd Edition, Feature Pack 2 devices.
  
Versions of the TTS API supporting S60 3rd Edition and S60 3rd Edition, Feature Pack 1 devices of the API can be requested via [http://www.forum.nokia.com/Developer_Programs/?categoryID=3 Forum Nokia API Partnering].
+
Versions of the TTS API supporting S60 3rd Edition and S60 3rd Edition, Feature Pack 1 devices of the API can be requested via [http://www.developer.nokia.com/Developer_Programs/?categoryID=3 Nokia Developer API Partnering].
  
Also note that low-quality TTS can be used via the <tt>CMdaAudioPlayerUtility</tt> class as well. More information is available [[Text to speech in symbian 2nd and 3rd edition phones|here]].
+
Also note that low-quality TTS can be used via the {{Icode|CMdaAudioPlayerUtility}} class as well. More information is available [[Text to speech in Symbian 2nd and 3rd edition phones|here]].
 +
<!-- Translation --> [[zh-hans:Text-To-Speech API二进制兼容的问题]]

Latest revision as of 09:50, 15 June 2012

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

TTS (Text-To-Speech) Utility API (CTtsUtility) is available in the SDK API Plug-in package for S60 3rd Edition, Feature Pack 2. Low-quality TTS is supported in all S60 3rd Edition devices, however there are binary compatibility breaks between each S60 3rd Edition platform release (S60 3rd Edition, Feature Pack 1 and Feature Pack 2) for this API.

Article Metadata
Tested with
Devices(s): S60 3rd Edition devices with HQTTS support (Nokia 5500 Sport, Nokia E50, Nokia E65, Nokia N75)
CompatibilityArticle
Keywords: CTtsUtility
Created: User:Technical writer 1 (March 4, 2008, updated October 3, 2008)
Last edited: hamishwillee (15 Jun 2012)

Note.pngNote: This API is not part of the public SDK. It can be found in the SDK API Plug-in.

[edit] Description

TTS Utility provides access to TTS functionality on S60 devices, including the high-quality TTS engine supported in some of the devices.

A list of devices supporting high-quality Text-To-Speech can be found here.

There are binary compatibility breaks between S60 3rd Edition releases for Text-To-Speech Utility and TTS Common APIs. Compiling an application using the TTS Utility API from the Plug-in package and trying to run it on an S60 3rd Edition device will result in KERN-EXEC 3 panic.

[edit] Solution

TTS APIs from the API Plug-in package can only be used on S60 3rd Edition, Feature Pack 2 devices.

Versions of the TTS API supporting S60 3rd Edition and S60 3rd Edition, Feature Pack 1 devices of the API can be requested via Nokia Developer API Partnering.

Also note that low-quality TTS can be used via the CMdaAudioPlayerUtility class as well. More information is available here.

This page was last modified on 15 June 2012, at 09:50.
180 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×