×
Namespaces

Variants
Actions
Revision as of 19:28, 31 October 2008 by extkbeditor2 (Talk | contribs)

Archived:Error message 'Cannot start ECMT Manager' in S60 3rd Edition Emulator (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search

Template:KBKI


Article Metadata
Tested with
Devices(s): Emulator
Compatibility
Platform(s): S60 3rd Edition
S60 3rd Edition, FP1
S60 3rd Edition, FP2
S60 3rd Edition FP2
S60 3rd Edition FP1
S60 3rd Edition (initial release)
Article
Created: (07 Aug 2008)
Last edited: extkbeditor2 (31 Oct 2008)

Description

If a system has only the latest Java Runtime Environment (JRE) version 6 installed, an attempt to open the Tools > Preferences menu in the emulator may fail with the "Cannot start ECMT Manager" error message.

Solution

Check that the version information of the JRE exists in the config.properties file used by the ECMT framework.

Open the following file in a text editor:

<SDK_Installation_Path>\epoc32\tools\ecmt\config\config.properties

and add the correct version of the installed Java Runtime at the end of the epdt.java.version.start property.

For example, in a system with JRE version 6 installed, add ",6.0" at the end of the line:

epdt.java.version.start=1.4.1,1.4.2,1.5,5.0,1.6,6.0

Then restart the emulator.

101 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×