×
Namespaces

Variants
Actions
(Difference between revisions)

Archived:Hardware/UI platform dependency not recognised in PKG file in Nokia N79 and Nokia N85 (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search
Forum Nokia KB (Talk | contribs)
hamishwillee (Talk | contribs)
m (Hamishwillee - Bot change of template (Template:KnowledgeBase) - now using Template:ArticleMetaData)
Line 2: Line 2:
 
__NOEDITSECTION__
 
__NOEDITSECTION__
 
{{KBKI}}
 
{{KBKI}}
{{KnowledgeBase
+
{{ArticleMetaData
 
|id=KIS001315
 
|id=KIS001315
 
|platform= S60 3rd Edition FP2
 
|platform= S60 3rd Edition FP2
Line 10: Line 10:
 
|creationdate=February 25, 2009
 
|creationdate=February 25, 2009
 
|keywords= 0x20002D86, 0x2000DA64
 
|keywords= 0x20002D86, 0x2000DA64
 +
 +
|sourcecode= <!-- Link to example source code (e.g. [[Media:The Code Example ZIP.zip]]) -->
 +
|installfile= <!-- Link to installation file (e.g. [[Media:The Installation File.sis]]) -->
 +
|sdk=<!-- SDK(s) built and tested against (e.g. [http://linktosdkdownload/ Nokia Qt SDK 1.1]) -->
 +
|devicecompatability=<!-- Compatible devices (e.g.: All* (must have GPS) ) -->
 +
|signing=<!-- Empty or one of Self-Signed, DevCert, Manufacturer -->
 +
|capabilities=<!-- Capabilities required (e.g. Location, NetworkServices.) -->
 +
|author=[[User:Technical writer 1]]
 
}}
 
}}
  

Revision as of 14:46, 24 June 2011


Template:KBKI

Article Metadata
Tested with
Devices(s): Nokia N85 (sw version 11.047), Nokia N79 (sw version 11.049)
Compatibility
Platform(s): S60 3rd Edition FP2
S60 3rd Edition FP2
Article
Keywords: 0x20002D86, 0x2000DA64
Created: User:Technical writer 1 (25 Feb 2009)
Last edited: hamishwillee (24 Jun 2011)


Overview

Hardware/UI platform dependency in a *.pkg file doesn't have any affect on the SIS installation file.

Description

ProductUID is a UID that identifies a specific phone or, more usually, a UI platform. The product UIDs of Nokia N85 and N79 are 0x20002D86 and 0x2000DA64, respectively, and both of them are missing the stub SIS files for their assigned product IDs. This makes it impossible to use a product-specific dependency in a SIS file.

Note that the product UID is in square brackets to distinguish a hardware dependency from a component dependency.

How to reproduce

Replace the hardware/UI platform dependency line in the *.pkg file with the following lines instead of the generic [0x101F7961], 0, 0, 0, {"Series60ProductID"}

 ;Supports Nokia N85 and N79
[0x20002D86], 0, 0, 0, {"Series60ProductID"}
[0x2000DA64], 0, 0, 0, {"Series60ProductID"}

Trying to install such a SIS package to the Nokia N85 and Nokia N79 returns the warning message: "Application not compatible - Install anyway?".

Solution

This problem is expected to be fixed in future software release.

As a workaround, the MachineUid variable can be used in .pkg files instead of a product-specific dependency.

For example:

 IF (MachineUID=0x20002D86) OR (MachineUID=0x2000DA64)
 ; If the device is Nokia N85 or N79, then install files in this block.
"\epoc32\release\armv5\urel\myapp.exe" -"!:\sys\bin\myapp.exe"
ELSE
 ; Otherwise popup a warning.
"compatibility_warning.txt"-"", FT, TC
ENDIF
49 page views in the last 30 days.