×
Namespaces

Variants
Actions
(Difference between revisions)

Archived:Highlight problem in 3rd-party MTM after deleting an e-mail in S60 3rd Edition FP1 (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search
hamishwillee (Talk | contribs)
m (Hamishwillee - Bot update - Fix metadata etc)
hamishwillee (Talk | contribs)
m (Removed protection from "KIS001043 - Highlight problem in MTM after deleting an e-mail": Merging into Wiki)

Revision as of 03:27, 15 March 2012

Article Metadata
Tested with
Devices(s): Nokia N95, Nokia E90 Communicator
Compatibility
Platform(s): S60 3rd Edition, FP1
S60 3rd Edition FP1
Article
Created: User:Technical writer 1 (19 Jun 2008)
Last edited: hamishwillee (15 Mar 2012)

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Description

List View's highlight in 3rd-party MTM applications does not appear on the correct row after deletion has taken place. For example, if an e-mail item is selected and then deleted, highlight skips one item.

How to reproduce

Using the following code in S60 3rd Edition, FP1 devices causes highlight to skip one item:

  CMsvOperation* CMyTextMtmUi::DeleteFromL(const CMsvEntrySelection& aSelection,
  TRequestStatus& aStatus)
  {
  return BaseMtm().Entry().DeleteL(aSelection,aStatus);
  }

Solution

There is no known solution for this issue.

88 page views in the last 30 days.
×