×
Namespaces

Variants
Actions
Revision as of 10:27, 20 July 2012 by hamishwillee (Talk | contribs)

Carbide.c++ FAQ

From Nokia Developer Wiki
Jump to: navigation, search
Article Metadata
Article
Created: frank_T (12 Apr 2007)
Last edited: hamishwillee (20 Jul 2012)

Needs-update.pngThis article needs to be updated: If you found this article useful, please fix the problems below then delete the {{ArticleNeedsUpdate}} template from the article to remove this warning.

Reasons: hamishwillee (30 Jun 2011)
This was written in 2009 in Carbide.c++ v2.0 timeframes. I've updated it with links to latest version (3.2) and fixed broken links. However it probably needs more detailed update. The official page may contains some of the required information.

Contents

Installation

The latest version of Carbide.c++ is version 3.2 as of 2011. The licensing of version 3.2 is free of charge and will give access to all versions of Carbide.c++.

Any developer who is using earlier versions should upgrade to the latest versions for many reasons. Users install multiple versions of Carbide on the PC, a good strategy for risk-adverse users.

License Issues

  • User license for Carbide.c++ has expired.
  • I want to transfer my Carbide license to another PC
  • I need to change my server for my Carbide floating license

Carbide.c++ is now free for all editions. Version 2.0 --> 2.0.2 still contains a Flex license which was installed by the installer. License issues with Carbide v2.0.0, 2.0.1, and 2.0.2 may arise for a number of reasons. To remedy the issues above the user has two options:

  • Install a temporary license file into your Carbide.c++ v2.0.x product.
    • Carbide license File.
    • Open up the Carbide IDE, select Help --> Carbide Licenses -->Install License and paste the contents of the license file above into the dialog box.


Getting Support

Where can I find the latest information on known problems and workarounds for Carbide.c++?

Read the release notes! Go to Help > Help Contents > Carbide.c++ User Guide > Release Notes. Many common problems are described there, along with workarounds.


How do I submit feedback to the Carbide.c++ Team?


How do I contact the Carbide.c++ support team?

The Carbide tools team monitors the Carbide.c++ Tools Discussion Board and is a great place for support. Logging bugs from Carbide is another good method (Help --> New bug report).


Building Projects

I have a project with hundreds of source files in it. When I try to build it, I get a linker error stating that the command line is too long. How do I fix this?

Shortening the project path should help. Either move it up as many levels as you can or simply rename the project folder and the folders above it so they contain fewer characters. Note that if you change the path you will need to add it to your workspace again via File > Import > Existing Projects into Workspace.


After upgrading to the latest version of Carbide I get warnings for an "Invalid Project Paths: Include path not found" and my project won't compile.

Be sure to switch to a different workspace instead of using the same one as before. You can choose "File" and "Switch Workspace" to create another one.

I get linker errors when I try to use more than one static library in a Carbide.c++ v1.1 project.

This was a known problem with Carbide.c++ v1.1, updating to the latest version will solve your problem.

Configuring Carbide

I'm trying to add a cust kit to the SDK Preferences window, but there is no Add button there, only a Remove one. How do I add a cust kit?

This feature is enabled by your license file, so there is probably something wrong with it. Licensing support for Carbide.c++ 1.x has finished and you are encouraged to upgrade to Carbide.c++ version 2.0 which does not have licensing problems as licensing is free.

I changed the variant .hrh file for my SDK but the changes do not appear to take. Why?

The macros from the *.hrh file(s) are collected and cached. To force a re-parse of the *.hrh file(s) you need to rescan SDKs by clicking Window > Preferences > Carbide.c++ > SDK Preferences > Rescan All SDKs.

Debugging

How can I debug an executable with one or more DLLs?

Use the Executable view inside of Carbide. EXE and DLL projects found in the viewer are all available to debug. The user can import executables too using the navigation icons found on the upper right hand side of the view.

NOTE Versions of Carbide before 2.0 operated differently when dealing with DLLs. Moving to the latest Carbide version should fix this problem.

How do I see debug messages with RDebug:Print in the console view?

Check "View Process Output" in the debug configurations panel. With that enabled, the debug messages will be shown in the "Debug Messages" console view.


Why doesn't the emulator debugger stop anymore when the user app panics?

This can be set in the emulator preferences by checking Tools > Preferences > C/C++ Debug > Just in time, or by setting the option directly in the epoc32\data\epoc.ini file by adding the line 'JustInTime debug'.

How to set Carbide.c++ as the default just-in-time debugger?

On WindowsXP this can be done through modifying registry key "Debugger" from path HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AeDebug, where full path to Carbide.c++ IDE executable file should be specified with arguments -p %ld -e %ld. Key "Auto" should be set to "1".

Importing Projects

I can't import any projects! Every time I try I get a lot of strange errors. What's wrong?

Be sure that there are no spaces in your workspace path. You can change your workspace path by selecting File > Switch Workspace.

When I import an mmp file in carbide I get the warning 'CTags not installed or not in path.' Have you encountered this problem before?

CTags is the default parser that is used in Eclipse, the warning is because you don't have it installed. If you want to get rid of the warning, open up the help system and look in the release notes for the information about this warning. There is a link in the release notes showing where to download CTags.


Profiler (Performance Investigator)

Is it possible to use the Profiler to see the Device Startup and AppShell Startup times?

Currently this isn't possible with the Developer/Pro versions. However, we are working to make this available in the next version of the tool.


Version Control

I'm using the Subclipse plugin and I get this error: "Workspace Path Validation Error"

Your Eclipse workspace path is c:\Symbian\Carbide\workspace

But the actual file system path is C:\Symbian\Carbide\workspace

The only difference between the two is the capitalized drive letter in the actual file system path. According to http://subclipse.tigris.org/faq.html#path-case, this is an issue with the Eclipse 3.1 (and probably earlier) platform.

It is very important to enter a capitalized drive letter in the workspace path to be able to use this plugin.

Editor

Why pressing the F3 key doesn't lead me to the definition of the symbol?

Try to right click on your project and select property, select "C/C++ Indexer" item and check the detail on right side: "Full C/C++ Indexer" should be the right value. Also you can try to reset the indexer: switch to "No Indexer" and press Apply, then switch back to the "Fast C/C++ Indexer". If there are many projects in your workspace it may take some time to create the index.

How do I force Carbide to use spaces rather than tabs?

Change the code style by going to Window > Preferences > C/C++ > Code Style > Edit, and then change the tab policy to 'Spaces only'.

Can I apply the code style to existing source?

Yes, you can apply the code style from Window > Preferences > C/C++ > Code Style to any text selection, or to an entire file, simply by using Edit > Format.

Misc questions

I've got an idea for a Carbide plug-in, how do I create one?

Carbide plug-ins are standard Eclipse plug-ins that can access project information specific to Carbide. Start by downloading the Carbide Developer Kit (CDK), available as an update through the Carbide.c++ Update Site. See Carbide.c++ User Guide > Carbide.c++ Overview > Introduction > Updating Carbide.c++ for more information.

See also

74 page views in the last 30 days.
×