×
Namespaces

Variants
Actions
Revision as of 03:54, 24 July 2013 by hamishwillee (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Desenvolvendo aplicações em Java ME usando Netbeans IDE

From Nokia Developer Wiki
Jump to: navigation, search
Article Metadata

Testado com
SDK: NetBeans 6.5.1

Artigo
Criado por ivocalado em 22 May 2009
Última alteração feita por hamishwillee em 24 Jul 2013

Este artigo apresenta uma visão geral das características da IDE NetBeans para criação de aplicações Java, mostrando através de uma simples introdução como criar uma aplicação móvel Java.

Contents

Introdução

A IDE NetBeans é um ambiente open-source de desenvolvimento baseado na plataforma NetBeans escrito totalmente na linguagem Java. A IDE NetBeans suporta o desenvolvimento de todo tipo de aplicação Java (tais como Java SE, Web, EJB e aplicações móveis Java ME). Entre seus vários recursos, estão um sistema de projeto baseado no projeto Apache Ant, controle de versão e ferramentas de refatoramento de código.

Para aplicações móveis, NetBeans apresenta muitos recursos de desenvolvimento rápido de aplicações (Rapid Application Development) (RAD), tais como editor visual de fluxo da aplicação (Visual Flow Designer), editor visual de formulários (Visual Form Designer), e ferramentas para desenvolvimento para vários dispositivos-alvos.

Para permitir o uso do NetBeans para construção de aplicações Java ME pelos desenvolvedores, a Nokia provê suporte ao NetBeans em muitos dos SDKs para dispositivos Série 40 (Series 40) e S60, incluindo todos os SDK dos dispositivos recentes da Série 40 5ª edição e dispositivos S60 3ª edição.

Um outro recurso disponível no NetBeans que pode ser de interesse do desenvolvedor é o plugin para criação de UML. Este plugin possibilita que os desenvolvedores criem diagramas de classe em UML. Além disso é possível efetuar uma sincronização entre o diagrama e o código desenvolvido. O plugin UML está disponível no pacote All do NetBeans or pode ser carregado para o NetBeans usando o gerenciador de plug-ins do IDE (selecionando as seguinte opções no menu: Tools -> Plugins).

A seguir são apresentadas alguns dos principais recursos disponíveis para o desenvolvimento de aplicações Java no NetBeans:

  • Ferramenta de auto-completar, facilitando a escrita do código.
  • Ajuda via Javadoc™
  • Muitos recursos para refatoramento de código;
  • Assistente de código;
  • Visualização do projeto;
  • Disponibilidade de muitas ferramentas adicionais e plug-ins.

A versão atual do NetBeans é a 6.5.1 e pode ser baixado de http://netbeans.org/downloads/index.html. Para o desenvolvimento de aplicações móveis Java, os desenvolvedores devem realizar o download dos pacotes da versão Java ou All, que oferece suporte ao desenvolvimento de Java ME

Download NetBeans

A seguir são apresentadas alguns dos principais recursos disponíveis para o desenvolvimento de aplicações móveis Java no NetBeans:

  • Editor visual de fluxo da aplicação (Visual Flow Designer);
  • Editor visual de formulários (Visual Form Designer);
  • Analisador de códigos;
  • Um sistema de compilação de projeto modular;
  • Suporte ao porte de aplicações;
  • Configuração das conexões sem-fio (disponível no pacote All);
  • Suporte ao desenvolvimento de gráficos vetoriais escaláveis para Java ME através da API JSR 226;
  • Várias opções de distribuição de aplicações, incluindo a distribuição para dispositivos Nokia usando o software Nokia PC Suite;
  • Suporte a projetos;
  • Ferramentas de desenvolvimento integrado;
  • Suporte a execução de testes usando J2MEUnit;
  • Suporte integrado a ofuscação e otimização de código;

Para conhecer mais sobre os recursos disponíveis, veja Nokia Developer NetBeans page.

Iniciando no NetBeans

Criando um novo projeto Java ME com NetBeans

Um projeto NetBeans contém informações sobre os arquivos do software e sobre as configurações do ambiente IDE. Para criar um novo projeto, selecione a partir do menu do NetBeans File -> New Project... ou use o atalho Ctrl+Shift+N. A figura a seguir apresenta a janela que será exibida.

NetBeans New Project.jpg

Escolha Java ME na lista Categories e após isso Mobile Application da lista Projects. Selecionando o botão Next será aberto a caixa de diálogo apresentada na figura a abaixo.

03 New Project.jpg

Defina um nome para o projeto e escolha onde o projeto deve ser salvo dentro de sistema de arquivos. Escolhendo a opção Create Hello MIDlet você irá criar uma simples aplicação no estilo Hello World, mas mais importante, ele irá inicializar na aplicação os editores para criação de fluxo e do layout das telas. Novamente, selecione o botão Next, e a caixa de diálogo apresentada na figura a seguir será exibida.

04 New Project.jpg

Se a opção Create Hello MIDlet não estiver selecionada, você terá de criar uma MIDlet manualmente após a criação do projeto. Para realizar esta tarefa, selecione File -> New File..., selecione MIDP na lista Categories e MIDlet na lista File Types . Pressione Next, nomeie sua nova MIDlet e pressione Finish.

Agora selecione a Plataforma do alvo da aplicação. É possível selecionar a maioria das SDK disponíveis para dispositivos S60 e Series 40. Neste exemplo, foi selecionado a versão S60 3rd Edition, Feature Pack 2 SDK for Symbian OS. Após esse estágio, o emulador para dispositivos S60 (S60Emulator) deve ser selecionado de forma a possibilitar o teste da aplicação desenvolvida no PC. Novamente, clique no botão Next, e a seguinte janela será exibida.

05 New Project.jpg

Esta janela possibilita adicionar configurações extras ao projeto. Para uma aplicação inicial, nenhuma configuração adicional é necessária, então simplesmente clique no botão Finish para completar a criação do novo projeto

Criando um fluxo para a aplicação, construindo telas e adicionando código

Uma vez que o projeto tenha sido criado, o NetBeans irá mostrar o editor de fluxo da aplicação (Flow Designer), como apresentado na figura abaixo.

NetBeans flow.jpg

O fluxo da aplicação é criado arrastando componentes da seção Displayables, localizado em Palette (no lado direito da janela da IDE) para o editor de fluxo.

Uma vez que o fluxo tenha sido criado, as telas individuais podem ser criadas. Isto é feito selecionando o componente e então selecionando a aba Screen no editor visual. Uma tela semelhante a da figura abaixo será exibida.

NetBeans screen.jpg

Da mesma forma De forma semelhante ao editor de fluxo, componentes de tela podem ser arrastados para o Device Screen e editados para criar o efeito desejado. Uma vez que a interface gráfica tenha sido projetado, o código pode ser modificado para implementar a lógica de negócio específica da aplicação. Selecione a aba Source para abrir o código. Uma tela similar a apresentada na figura será exibida.

NetBeans source.jpg

Quando o código é visualizado, todo o código gerado pelos editores de fluxos e telas é minimizados em blocos de códigos rotulados Generated.... Expanda esses blocos de códigos para ver o código gerado destacado em cinza. Este código não pode ser alterado. A lógica de negócio pode ser inserido nas seções de código que não estejam destacados.

Com estas ferramentas, aplicações podem ser desenvolvidas de forma relativamente rápida. Além disso, vale salientar que o NetBeans provê recusos de forma a aproveitar as vantagens dos conteúdos da JSR 226 e SVGT. A JSR 226 possibilita que recursos gráficos possam ser criados com ferramentas tais como Adobe Illustrator e Ikivo Animator, eliminando a necessidade de programar gráficos para menus e um amplo conjunto de telas de aplicações. Um screecast descrevendo como usar a JSR 226 está disponível aqui e um exemplo complementar está disponível aqui.

Construindo o projeto e executando a aplicação no emulador

Tendo criado a aplicação do o editor visual (Visual Designer) e adicionado toda a lógica de negócio, salve o projeto selecionando File -> Save (ou usando o atalho do teclado Ctrl+S). Agora o projeto pode ser construído. Para fazer isso, selecione Run -> Build Main Project (ou pressione a tecla F11). O NetBeans irá iniciar a compilação do projeto, como apresentado na figura a seguir. Informação do processo de construção é mostrado na janela Output na parte inferior da IDE.

NetBeans build project.jpg

Se não houver erros durante o processo de construição, o projeto pode agora se executado no emulador para dispositivos S60. Para fazer isso, selecione no menu do NetBeans Run -> Run Main Project ou pressione F6. Inicialmente, uma janela mostrando o progresso do processo de inicio da aplicação é apresentado, como mostra a figura abaixo.

10 New project SDK launch.jpg

O emulador é então aberto e a aplicação iniciada, como mostra a figura a seguir.

11 Emulator.jpg

A aplicação pode ser agora testada para confirmar se ela se comporta da maneira esperada. Uma vez que os testes tenham sido realizados, a aplicação pode ser fechada; no entanto, o emulador deveria permanecer aberto se mais testes estiverem planejados. Deixando o emulador aberto há uma melhora na velocidade com a qual uma aplicação pode ser carregada no emulador, devido ao fato de que não vai ser necessário iniciá-lo.

Instalando o MIDlet em um dispositivo Nokia

Quando o projeto é construido, o NetBeans cria sua Suite de MIDlets, consistindo de um arquivo JAD e um arquivo JAR. Estes arquivos são encontrados no diretório /dist. Se a aplicação Nokia PC Suite estiver instalado no PC, o módulo de distribuição de aplicações do NetBeans pode ser usado para instalar a aplicação diretamente no dispositivo Nokia conectado ao PC via bluetooth, infravermelho ou até USB.

Para usar este recurso, o projeto precisa estar configurado com a configuração de distribuição (deployment). Para habilitar este recurso você deve alterar as propriedades do projeto, selecionando no menu do NetBeans File -> Project Properties. Na janela de propriedades, mostrada na figura abaixo, selecione a opção Deploying da lista Category do lado esquerdo da tela.

12 deploying.jpg

Agora selecione Nokia Terminal connected via PC Suite como método de distribuição, e salve as propriedadesas. Após isso, selecione Deploy no menu de contexto do projeto. A aplicação será agora enviada para o dispositivo conectado ao PC, onde ele será instalado da maneira usual. Uma vez instalada, a aplicação pode ser executada da mesma forma como se tivesse sido instalada pelo usuário.

Informações adicionais sobre como distribuir uma aplicação para um dispositivo está disponível no artigo (em inglês) aqui.


Mais Informações

Esperamos que está pequena introdução tenha mostrado como é poderoso e conveniente a IDE NetBeans para criação de aplicações Java ME. Há muito mais informações sobre como criar aplicações Java ME para dispositivos Nokia neste Wiki e também em Nokia Developer website.

Para mais informações em como iniciar no mundo NetBeans, o Nokia Developer tem um screecast que mostra o processo de download e instalação de todas as ferramentas para o NetBeans 5.5.1 e como criar um simples projeto; ele pode ser baixado em aqui. Um screencast atualizado abordando a versão 6.0 do NetBeans está disponível em aqui.

Você pode encontrar mais informações em NetBeans web page.

Este artigo é uma tradução do artigo em inglês NetBeans.

This page was last modified on 24 July 2013, at 03:54.
230 page views in the last 30 days.
×