×
Namespaces

Variants
Actions
(Difference between revisions)

Archived:Location.getCourse() and Location.getSpeed() not working in S60 3rd FP1 Emulator (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search
schoenke (Talk | contribs)
(Initial version)
 
hamishwillee (Talk | contribs)
m (Hamishwillee - Bot change of template (Template:KnowledgeBase) - now using Template:ArticleMetaData)
Line 2: Line 2:
 
__NOTOC__
 
__NOTOC__
 
__NOEDITSECTION__
 
__NOEDITSECTION__
{{KnowledgeBase
+
{{ArticleMetaData
 
|id=Unofficial - No ID assigned|platform=S60 3rd Edition, FP1
 
|id=Unofficial - No ID assigned|platform=S60 3rd Edition, FP1
 
|devices=Emulator
 
|devices=Emulator
Line 9: Line 9:
 
|creationdate=May 3, 2009
 
|creationdate=May 3, 2009
 
|keywords= Location getCourse() getSpeed()
 
|keywords= Location getCourse() getSpeed()
 +
 +
|sourcecode= <!-- Link to example source code (e.g. [[Media:The Code Example ZIP.zip]]) -->
 +
|installfile= <!-- Link to installation file (e.g. [[Media:The Installation File.sis]]) -->
 +
|sdk=<!-- SDK(s) built and tested against (e.g. [http://linktosdkdownload/ Nokia Qt SDK 1.1]) -->
 +
|devicecompatability=<!-- Compatible devices (e.g.: All* (must have GPS) ) -->
 +
|signing=<!-- Empty or one of Self-Signed, DevCert, Manufacturer -->
 +
|capabilities=<!-- Capabilities required (e.g. Location, NetworkServices.) -->
 +
|author=[[User:Schoenke]]
 
}}
 
}}
  

Revision as of 14:48, 24 June 2011

Template:KBKI


Article Metadata
Tested with
Devices(s): Emulator
Compatibility
Platform(s): S60 3rd Edition, FP1
Symbian
S60 3rd Edition FP1
Article
Keywords: Location getCourse() getSpeed()
Created: schoenke (03 May 2009)
Last edited: hamishwillee (24 Jun 2011)

Description

To get a LocationProvider that provides current speed and course, the criteria have to be set accordingly before retrieving the instance of LocationProvider:

Criteria criteria = new Criteria();
criteria.setSpeedAndCourseRequired(true);
LocationProvider locationProvider = LocationProvider.getInstance(criteria);

This works fine for S60 3rd FP1 devices. But if the setSpeedAndCourseRequired criterion is set in the emulator, the call of getInstance() always returns null.

The purpose of an emulator is voided if it doesn't behave like the devices it represents...

How to reproduce

just try it as described above...

Solution

Fix this non-conformity... and in the meantime document it as a Known Issue

55 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×