×
Namespaces

Variants
Actions
(Difference between revisions)

Talk:Qt Tutorials for Intermediate : How to vibrate the device using S60 API on Qt

From Nokia Developer Wiki
Jump to: navigation, search
lucarocchi (Talk | contribs)
(hapticfeedback: new section)
michael-sh (Talk | contribs)
(Michael-sh - Seems not to work with S60 5th edition?: new section)
 
Line 21: Line 21:
 
Thanks a lot  
 
Thanks a lot  
 
Luca
 
Luca
 +
 +
== Michael-sh - Seems not to work with S60 5th edition? ==
 +
 +
I tried to incorporate your code to my existing S60 5th Edition Project running on a XPressMusic 5800, using Qt 4.7.3. When compiling, I reveive 4 errors, 1. one says: c:\Users\Public\Documents\Symbian-Projekte\sStoppuhr\mainwindow.cpp:30: Fehler:'hapticFeedbackControl' was not declared in this scope
 +
 +
Could it be that this code does not run with Qt 4.7.3?
 +
 +
kind regards,
 +
 +
Michael<p style="text-align:right">[[User:Michael-sh|Michael-sh]] 20:42, 12 February 2013 (EET)</p>

Latest revision as of 21:42, 12 February 2013


Hi Sittiphol,

Why are " -lcone -leikcore -lavkon" needed? ;-)

You can remove them I guess.

croozeus 11:28, 23 November 2010 (UTC)


[edit] hapticfeedback

your article should be taken as template ...

first it is very useful for who , as me , needs to integrate Symbian with Qt , and sure vibra makes the app coolest

second , you do not forget any info ... i mean includes files , libs , class cpp/h, and finally the line to call it

third ... it works at first shot for me

Thanks a lot Luca

[edit] Michael-sh - Seems not to work with S60 5th edition?

I tried to incorporate your code to my existing S60 5th Edition Project running on a XPressMusic 5800, using Qt 4.7.3. When compiling, I reveive 4 errors, 1. one says: c:\Users\Public\Documents\Symbian-Projekte\sStoppuhr\mainwindow.cpp:30: Fehler:'hapticFeedbackControl' was not declared in this scope

Could it be that this code does not run with Qt 4.7.3?

kind regards,

Michael

michael-sh 20:42, 12 February 2013 (EET)