×
Namespaces

Variants
Actions
Revision as of 07:53, 20 September 2012 by hamishwillee (Talk | contribs)

Template:ArticleNeedsUpdate

From Nokia Developer Wiki
Jump to: navigation, search

Apply this template to the top of articles that require a specific update or testing to improve quality or to bring them "up to date".

Usage

 {{ArticleNeedsUpdate|timestamp={{subst:CURRENTTIMESTAMP}}|user=~~~|Text explaining issues(required)}}

The parameters are required:

  • timestamp: Apply a timestamp so it is clear when the suggestion was made. Usually just copy-paste timestamp={{subst:CURRENTTIMESTAMP}}
  • user: User id of person recording issue. You can use the wiki syntax ~~~ to add your user id
  • Unnamed parameter: Text explaining what changes or testing is needed.

Optional parameters:

  • type: A short string for the type of update required. For example, one of: copyediting, code formatting, technical review. This is optional, but if specified will replace the text "to be updated" when the template is displayed.
  • language: The language category of the natural language the template is to display in. If no language is specified or if the specified language is not supported then the English version is used.
    • Translations exist for: Lang-Portuguese, Lang-Chinese, Lang-Russian, Lang-Bahasa Indonesia
    • For example:
      {{ArticleNeedsUpdate|language=Lang-Chinese|timestamp=...}}

      Needs-update.png本文需要更新: 如果您发现这篇文章有用,请修复下面的问题,然后从文章中删除 {{ArticleNeedsUpdate}} 模板,以消除此警告。

      原因: hamishwillee (20 Sep 2012)
      请说明需要更新的理由。

      Needs-update.pngEste artigo precisa ser atualizado: Se você achou esse artigo útil, por favor corrija os problemas relatados abaixo e depois retire do artigo o modelo {{ArticleNeedsUpdate}}, para que este aviso seja removido.

      Motivos: hamishwillee (20 Sep 2012)
      POR FAVOR, EXPLIQUE PORQUE O ARTIGO PRECISA SER ATUALIZADO.

      Needs-update.pngДанную статью необходимо обновить: Если Вы считаете эту статью полезной, пожалуйста, исправьте указанные ниже проблемы, после чего удалите шаблон {{ArticleNeedsUpdate}} из статьи, чтобы убрать это предупреждение.

      Причины: hamishwillee (20 Sep 2012)
      ПОЖАЛУЙСТА, УКАЖИТЕ ПРИЧИНУ (ПРИЧИНЫ) ОБНОВЛЕНИЯ.

      Needs-update.pngArtikel ini perlu diupdate: Jika anda berfikir artikel ini bermanfaat, anda dapat membantu menyelesaikan masalah di bawah lalu menghapus template {{ArticleNeedsUpdate}} untuk menghilangkan peringatan ini.

      Alasan: hamishwillee (20 Sep 2012)
      MOHON BERIKAN ALASAN KENAPA HARUS DIUPDATE.

Articles which use this template

[show details]


Default appearance

The default appearance of the template, without the unnamed explanatory parameter specified, is shown below:


Needs-update.pngThis article needs to be updated: If you found this article useful, please fix the problems below then delete the {{ArticleNeedsUpdate}} template from the article to remove this warning.

Reasons:
PLEASE STATE REASON(S) FOR UPDATE.

240 page views in the last 30 days.