×
Namespaces

Variants
Actions
Revision as of 08:32, 1 August 2013 by hamishwillee (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Using Nokia SDKs and Tools on Windows Vista

From Nokia Developer Wiki
Jump to: navigation, search

Needs-update.pngThis article needs to be updated: If you found this article useful, please fix the problems below then delete the {{ArticleNeedsUpdate}} template from the article to remove this warning.

Reasons: hamishwillee (20 Aug 2012)
bcdedit is mentioned once but not explained - can possibly get information from here: Archived:Possible workarounds to Emulator startup issues on Vista in S60 3rd Edition.

Article Metadata
Code ExampleCompatibility
Platform(s): S60 3rd Edition through to Symbian^3
Symbian
Symbian^3
Article
Created: jimgilmour1 (15 Jul 2007)
Updated: jimgilmour1 (12 Jul 2010)
Last edited: hamishwillee (01 Aug 2013)


This article documents what Symbian and Nokia SDK software will work on Windows Vista(tm). It is updated reguilarly as new versions become available.

Contents

Latest Updates

12-July-2010

Symbian ^3 kit will know when the Vista patch is applied.
The program SVGTBinEncode.exe needs replacing with two files from the
S60 5th Edition 1.0 kit. See Symbian ^3 section below.
Qt 4.6.3 or later must be used failures occur for earlier versions

21-July-2010
ActivePerl 5.6.138 has been replaced by version 5.10.1 see below

22nd Feb 2010

Suppliers of free third party products (non-nokia) have removed
them from websites back up to permanent storage
i.e. burn to CD all products needed for personal use in this article

Hosting or Placing these products on other websites is not legal

 16th Jan 2009 - for WINDOWS 7

Error: Bareword "GCCE" not allowed while "strict subs" in use at Solution: The official Vista Plugin patch supplied in S60 5th Edition applied and the error was still there;
I have changed from file C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\BUILD\S60Workspace\YOUR_APP\group\PLATFORM.PM the lines:
%FeatureVariantSupportingPlats=(
GCCE - COPY=>1,
GCCE=>1,
GCCEV6=>1,
GCCEV6T2=>1,
GCCEV7A=>1
);

with this:
%FeatureVariantSupportingPlats=(
);
just cut the linecodes where the err was... and the compile works until the end...

28th December 2008
The most important announcement this year. The launch of Carbide.c++ v2.0 which is
working correctly with Windows Vista and in the Carbide.c++ v2.0 all versions are FREE. Express version
does not exist and Developer version takes over as the base version. 


 13th October 2008

S60 5th Edition 0.9 provides a Vista patch for GCCE in the distribution kit AFTER install see "C:\S60\devices\S60_5th_Edition_SDK_v0.9\Plugins\vistapatch". The emulator works with the Belkin Bluetooth USB Stereo USB model F8T013 see below. The official Vista Plug-in patch supplied in S60 5th Edition appears to work with earlier S60 3rd Edition SDK under Vista see below

Eclipse Ganymede have been successfully tested under Vista


 4th July 2008 
Error: Error starting debug process Code 87 57
Solution: Perform following steps. * Close your running instance of Carbide.c++ IDE. * Go to your Carbide.c++ installation path. e.g: C:\Program Files\Nokia\Carbide.c++ v1.2\ * Right click on Carbide.c++.exe Properties-> Compatibility-> Compatibility Mode-> Windows Server 2003(...)-> Apply-> OK * Open Carbide.c++ IDE again. * Clean your project * Rebuild your project * Start debugging --kiran10182 19:00, 4 July 2008 (EEST)



 18th May 2008 

Error: Bareword "GCCE" not allowed while "strict subs" in use at Solution: The official Vista Plugin patch supplied in S60 5th Edition appears to work with earlier S60 3rd Edition SDK under Vista see below




24th April 2008

Update notes about Windows Vista Service Pack 1 install and Windows XP Service Pack 3 install and Vista disk defragmentation answers


30th May 2008

Adobe Flash Player identified as stopping Vista IE7 see item from Adobe on removal of old versions Adobe Knowledge Base

There has now been a critical security alert that an early versions of Flash player may have been compromised this and can alter websites remove the current version using the link to remove the player and get the updated version that does not contain this vulnerability Install Get Adobe Flash Player 9.0.124.0. This may affect Windows XP users as well.





16th March 2008

Environment: Carbide c++ 1.2.2.5 on Vista Home Premium and sdk S60 3rd Ed FP1

Linker error: arm-none-symbianelf-ld: cannot find -lsupc++

Solution: lsupc++.a is a library contained in "C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\lib" so it's necessary to edit the file C:\Symbian\9.2\S60_3rd_FP1\Epoc32\tools\compilation_config\gcce.mk and modify the value of parameter SYMBIAN_UREL_LINK_FLAGS adding -L"C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\lib" (PS: Make sure that it should not be in a new line --kiran10182 ). My resulting line is:

SYMBIAN_UREL_LINK_FLAGS=$(SYMBIAN_LD_MESSAGE_OPTION) $(BPABI_OPTION) $(RELOCATABLE_IMAGE_OPTION) $(TARGET_RELOCATION_OPTION) $(UNRESOLVED_SYMBOL_REF_OPTION) $(STDLIB_OPTION) $(EXTRA_LD_OPTION) -L"C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\lib"


slibrenti@mobtec.it

In my case we have to add -L"C:\Program Files\CSL Arm Toolchain\lib\gcc\arm-none-symbianelf\3.4.3" to the link above.

SYMBIAN_UREL_LINK_FLAGS=$(SYMBIAN_LD_MESSAGE_OPTION) $(BPABI_OPTION) $(RELOCATABLE_IMAGE_OPTION) $(TARGET_RELOCATION_OPTION) $(UNRESOLVED_SYMBOL_REF_OPTION) $(STDLIB_OPTION) $(EXTRA_LD_OPTION) -L"C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\lib" -L"C:\Program Files\CSL Arm Toolchain\lib\gcc\arm-none-symbianelf\3.4.3"

and for debug on device add string like this

  1. Linker option common to all link commands for UDEB build

SYMBIAN_UDEB_LINK_FLAGS=$(SYMBIAN_LD_MESSAGE_OPTION) $(BPABI_OPTION) $(RELOCATABLE_IMAGE_OPTION) $(TARGET_RELOCATION_OPTION) $(UNRESOLVED_SYMBOL_REF_OPTION) $(STDLIB_OPTION) $(EXTRA_LD_OPTION) -L"C:\Program Files\CSL Arm Toolchain\arm-none-symbianelf\lib" -L"C:\Program Files\CSL Arm Toolchain\lib\gcc\arm-none-symbianelf\3.4.3"

oberstet: I had to do the same to get S60 SDK FP1 work on XP Prof. SP3 from the command line.






19th September 2007

APP Trk debug works on Carbide 1.2.2 S60 3rd Ed FP1 and Nokia N95 via USB
27th July 07 ** S60 3rd FP1 GCCE Patch added ** 
25th July 07 Added the S60 3rd Edition patch for Vista with
S60 9.1 S60_3rd see index
10th August 07 Series 40 5th Edition SDK added way to install on Vista
30th August 07 Bluetooth Belkin driver for Nokia PC Suite support on Vista
19th September 07 (by kcomex
) In Windows 2003 Server R2 which is 
     released even later than Vista, the problems observed here happened the 
     same. Probably because of the windows kernel update, so for most stability 
     demand, it is strongly recommended you run a Windows Server 2003 (NON-R2) 
     if you dislike win XP.
15th October 07 S60 3rd Edition FP2 Beta Patch added makes self sign sis
                in Carbide.c++ 1.2.2
Sun Wireless Toolkit 2.5 CLDC (tm) success installed and running. 
Tested S60 2nd Edition FP3 version 8.1a success install and 
Carbide.c++ 1.2 build. The emulator runs in standalone


--jimgilmour1 15:24, 11 September 2008 (UTC)


Introduction


Recently an update to IE 7 was forced into XP SP2.

UPDATE:- January 2009 Windows Vista Update will be trying to send IE8 soon. There is an IE8 blocker even more important for Firefox users to run this patch. Save the patch and run from the Command shell i.e.
"C:\ie8blocker>IE80Blocker.cmd %USERDOMAIN% /B"
to allow IE8 use /U.

In April 2008 Microsoft has announced the entry of final release Service Pack 3 for Windows XP.

If you have a PC brand, for example (NEC, Packard Bell, Acer), which has built in Windows XP they have ability to reload from the F11 function key. Of course you need to back up everything to another PC! or backup drive. When reloaded add the service pack 3 for XP. The filename used is "windowsxp-kb936929-sp3-x86-enu_9afedbd6b2941bf568c27046d6688e6ccb5ce018"

This has given about 10% speed improvement and works well does NOT add IE7, so Firefox can be loaded. The important part is to defragment,several times, to your hard disk after loading Service PAK's regardless of the program says, until there no change.

Since then IE6 has been failing with unknown errors, so the upgrade to IE7 have been done along with Adobe Flash 9.

The Carbide 1.2 c++ and S60 3rd Edition FP2 were loaded and there is a considerable improvement in performance in build times.

Now lets try Vista, in my case the Service Pack 1 has previously been copied to CD ROM and DID NOT use the Windows Update, this came back with an strange error number/code.

Just use the update file. with five languages support Windows Vista SP1 5 languages 434 Mb

When the service pack has installed after approximately 75 minutes, defragment your drive using the command shell at the Vista command prompt c:\> enter the command

C:\Windows\system32>defrag -w -v c:

The important switch here is the -w as this changes Vista default of ignoring smaller files. This may need to be run twice and will take several hours, an overnight batch file may be useful. If you need to "see" the fragmentation of drive the original application is called Diskeeper and is a 31 day trial.

The announcement on 13 April 2007 of then "end-of-sales-life" in December 2007 for Windows XP means that replacement PC's will contain Windows Vista(TM). In some countries all PC's are already Vista only. This means a massive testing and documentation project. The aim is to check and test all version of Nokia and Symbian and dependent software for success. The main object is to test the latest version and document which combinations work.

Early versions say that Carbide 1.1 may fail but its version 1.2 will install and work with a small patch, then no attempt will be made to fix version 1.1.

The general idea is that there is enough information to make an informed choice as to when and if to upgrade.


Jim Gimour Nokia Developer Champion

Updated 24 April 2008

Whats this Project objective

Simply document what Symbian and Nokia SDK software will work on Windows Vista(tm) as an on going source of information, updating as versions become available

Most Common problem in Vista (tm) SDK installs

The main change in installing SDK's on Windows Vista (TM), any version, is that on setup.exe you must right click and select "Run as Administrator". You need to copy the application shortcut from Start-bar to desktop and change Properties to Compatibility to "Run as Administrator" and Windows XP Service Pack 2

Administrator rights have always been required on XP Professional and Windows server install. In Vista every version has at least one Administrator account. When connected to a Windows domain your may need to use the local machine Administrator account, contact your network administrator.


The following steps, in order, provide an easy and user friendly way of installing SDK's that are not fully supported by Windows Vista:

  • Start the Program Compatibility Wizard by entering the following line in Start -> Start Search
  •  %systemroot%\System32\mshta.exe res://acprgwiz.dll/compatmode.hta
  • Select the SDK's setup.exe
  • Select install as in Windows XP SP2
  • Do not select any of the options for graphic issues (if you don´t have graphic issues otherwise select the most suitable option to solve it)
  • The following "Run as administrator" option can only be selected if you are not an administrator but it can be convenient to select it if this is the case.
  • Select the following option to always run this setup according to the previously selected options.


This procedure was used and validated for the Nokia 6131 NFC SDK in combination with Windows Vista Ultimate.


Carbide installer may abort during installation in windows vista environment with the following message: unhandled exception Error Number: 0x80040708 Description: (0x80004005). This can be solved by disabling DEP (data execution protection) using bcdedit.exe command. This also may be needed during upgrade of modules attached to carbide.

Vista - File Virtualization

There is a know issue with Vista's File Virtualization feature (see [1] for a bit more info) which makes the Program Files branch of the file system read-only for most applications. A copy of the devices.xml file is being updated but not under c:\Program Files\Common Files\Symbian but in the Virtual Store directory (under your user profile directory) so in this case one will have to manually copy the file from this virtual location to the real one in order to make the changes visible for all the tools.

Running the SDK installer as Administrator (as recommended in S60 SDK and tools on Windows Vista - a success story) should in fact help avoiding this problem.


Vista runs slow after installing Mobile products

Windows Vista and Mobile products work much better with 2GB of memory updgrading by adding an extra 1GB now memory prices are very low.

When you have installed all the products defragment your disk. This might seem like simple answer, but Vista Defragementer does NOT work in its default use with the scheduler

Defragment your drive using the command shell at the Vista command prompt c:\> enter the command

C:\Windows\system32>defrag -w -v c:

The important switch here is the -w as this changes Vista default of ignoring smaller files, working like Windows XP. This may need to be run twice and will take several hours, an overnight batch file may be useful. If you need to "see" the fragmentation of drive the original application is called Diskeeper and is a 31 day trial.


There is now a free defragment program with GUI which runs on Vista, this takes some time to run,but can run using Aero semi visible display in background and minimised. called MyDefrag (previously known as JkDefrag)

There are a couple of answers. If you have a dual boot Vista and XP machine then you can use XP which will work. There is another article with a workaround on the tips-defrag-windows-vista-faster

Vista Dual-Core with 1GB Memory gave a 20% to 50% increase on loading Carbide.c++ 1.2.2 and 10% and 15% whilst running.

Window Vista driver problems

  • 'RealTek High Definition Audio Drivers'

error in MMFAudioserver.exe exits status code -5

From Control panel Disable RealTek High Definition Audio from Vista Control Panel -> Device Manager

Right click on the speaker icon, Select disable, click 'ok' to close

A little yellow triangle appears against the speaker. See the original Forum post RealTek HD Audio failure reason

  • Update 14th October 2008

The cheapest and easiest way is try use a Belkin Bluetooth Stereo USB adaptor and Nokia Stereo headset and install using Belkin Vista Driver as the main sound output. This solution works really well for laptops running Vista where hardware cannot be changed or removed, by adding the bluetooth sound driver. Now you make a short cut to the "Sounds" icon from Control Panel to Desktop. Then using "Sounds" icon select the Bluetooth headset as default sound driver, even with the RealTek Audio, or any other hardware is enabled.


In emulator crash the epocwind.out shows MMFAudioServer.exe and MMFAudioPolicyServer killed -5 for the KeySoundServerThread PANIC are due to RealTek Hardware drivers being a problem in Vista and Windows XP


The S60 3rd Edition (BASE) dated 11-December-2005 emulator

path C:\Symbian\9.1\S60_3rd\Epoc32\Release\Winscw\Udeb\Epoc.exe will run successfully. The bluetooth speakers solution above seems to allow the all the vrsions of S60 3rd Edition to work. The built in speaker drivers can be re-enabled as long as bluetooth speakers are the default audio output.

When buying a new PC consider if the audio card hardware has compatible signed drivers, sometimes the card may be to complex, and loads drivers which override eg Microsoft Audio HD drivers


  • 'Java (tm) Runtime Problems'

Load Sun runtime for Vista (1.6.01 upwards). To gain support for version 5 runtime you must load jre_1.5.0_15 onwards NOT jre_1.5.0_05. Uninstall jre_1.5.0_05 if this is installed.


  • 'Vista's DEP (Data Execution Protection)'

It has been noted on some occasions that DEP prevented the emulator (epoc) to run normally. It is recommended to turn DEP off (System properties->Advanced System Settings->Advanced->Performance Settings->Data Execution Prevention->Turn on DEP for essential Windows programs and services only)


  • ' Adobe Flash Player ActiveX possibly causing slowness in Web browsing'

Flash Player identified as stopping Vista IE7 see item from Adobe Knowledge Base Broadband wireless connection wrongly identified causing slowness. Vista Problem Reporting identified problem on Adobe Knowledge Base This may impact emulator testing of Flash

Jim Gilmour 23rd May 08

Mobile products which work with Windows Vista (tm)

Nokia PC Suite Version 6.8.163 ownward works with Vista

Belkin have announced a bluetooth driver which supports Vista Microsoft Bluetooth making support for Nokia PC Suite 6.8.163 and above

Belkin Vista Driver

Belkin Vista Driver

BlueSoleil Vista Driver

http://www.bluesoleil.com/products/productcatalog-all-0-data-desc-1.html


The following significant changes have been made to BlueSoleil 3.2.2.8 Release since its build 3.2.1.2 release:

Support PC Suite better on Vista. Make the online activation more stable.

Old Nokia PC Suite versions

Versions such as Nokia PC Suite for Nokia 6600 (5 years old) are not expected to work.

Status: There is no intention to fix these early versions


Carbide.C++ Version 2.0

Carbide.C++ 2.0 Now supported Vista without adjustments. You can use OEM version WITHOUT needing to buy a license. There will be people still using version 1.3 and therefore need the information below. New users and those with new projects should start using Carbide version 2.0 and the official Vista patches for S60 5th Edition. Follow the preparation instructions for Carbide v1.3 for Vista below and finally install Carbide.C++ 2.0

Carbide.c++ versions 1.2 and 1.3

Carbide.c++ v1.2 and 1.3 are Vista compatible, but needs some adjustments to install and operate correctly.

Install Sun Java Runtime for Vista

  • Install "Sun Java Runtime for Vista" ! not 1.5, but version 6 from Sun Java(tm) Runtime. Selected Windows online installation. This appears to load version 6 and later on reboot version 6.02 was loaded via update. This is also called version 1.6.02 further updates are downloaded when ready.
  • On the .msi right click "Run as Administrator".

Install Active Perl version 5.10.1 replaces 5.6.1.638

Important Update 1st Feb 2010:- This version of Perl have been taken down
Important Update 10th Oct 2011:- Current version available for download is 5.12.4

Make copies to permanent media ie burn data CD of current copies

  • Install ActivePerl-5.10.1. Make sure you install version 5.10.1 replaces 5.6.1.638, not the 5.8xxx. During installation of SDK's the installer will complain about lack of 5.6.1.638, just click continue.

Be sure to also add ";c:\Perl\bin" to the PATH environment variable (there is also an option for this during installation but you might need to add it manually).

  • Perl installation might fail if the check boxes are checked which provides an options to add path and file association, in that cases un-check those options and then retry again, it worked in my case, then add the path manually as mentioned above
  • On the Carbide 1.2 or 1.3 setup.exe right click "Run as Administrator".

You can change the PATH variable at My Computer > Properties > Advanced System Configuration > Environment Variables > System Variables. You'll be asked to give Administrator Permission during the process.

  • Perhaps the most important steps. In the Vista startup bar an icon has been made to start Carbide 1.2 right click and select copy, go on to the desktop and right click and select paste.
  • Right click on the Carbide shortcut select the "Compatibility". Click the button "Run this program in compatibility mode for" Windows XP (Service Pack 2)
  • Click the box marked "Run this program as an Administrator", then click "Apply" then click ok.

You can now use the icon to start Carbide and create and build the hello project template using the S60 3rd Edition and the patch available below.

In Windows Vista and XP you must have the workspace on the same drive and do not use spaces in your workspace the default "C:\Symbian\Carbide\Workspace", possibly adding 12 for v1.2 and 13 for v1.3, to allow a specific workspace for each version of Carbide. Use the Migrate tool to move from older versions of the s60 2nd,3rd to 5th edition.

S60 5th Edition v1.0

The version has a official version for use with Vista in the plugins folder. This is a new version of GCC.MK which supports the Vista paths along with an ENV.BAT which sets up the paths for Vista compilation. Install with "Run as Administrator". Use the bluetooth speaker as described above if the Sound drivers cause problems. The installer will not find ActivePerl version 5.6.1.638 and give an error message to continue click yes and ok to continue SDK installation

Using the Vista patch S60 5th Edition v1.0 on previous versions

The Vista patch from S60 5th Edition v1.0 can be used for Symbian S60 3rd Edition MR onwards by simply copying GCCE.MK from patch to C:\Symbian\9.1\S60_3rd_MR\Epoc32\tools\compilation_config and run the ENV.BAT as described in the patch readme.txt

Using this patch this appears to cure all problems described below for S60, the patches are being left here in case there is a need for them and because reference is made to the patches elsewhere in this article

Symbian ^3

This kit is used for the Nokia N8 smart-phone. On Vista this does kit does not work when compiling using install verification. There is a large Vista driver error message come up whilst trying to "abld build" the helloworld example, causing failure. The fix to this is described below
Rename the original
C:\> cd C:\Nokia\Devices\Nokia_Symbian3_SDK_v0.8\epoc32\tools
C:\Nokia\Devices\Nokia_Symbian3_SDK_v0.8\epoc32\tools>ren svgtbinencode.exe svgtbinencode-s3.exe

Copy C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\tools\SVGTBinEncode.exe and
Copy C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\tools\xerces-c_2_6.dll to C:\Nokia\Devices\Nokia_Symbian3_SDK_v0.8\epoc32\tools

The Qt 4.6.3 will compile and create sis the main problem is that the bld.inf needs to be changed

prj_platforms

WINSCW GCCE ARMV5 ARMV6

becomes
prj_platforms

WINSCW GCCE

This will now work without the RVCT kits. The reason for this and SYSTEMINCLUDE is that RVCT_Symbian 4.0 or v2.2 is assumed to be available

S60 2nd Edition

  • Symbian S60 2nd Ed FP2

Unzip distribution On setup.exe right click "Run as Administrator".

  • Symbian S60 2nd Ed FP3

Unzip distribution On setup.exe right click "Run as Administrator". Installs and runs under Carbide.c++ 1.2 without any problems The emulator runs in standalone


Symbian S60 3rd Edition

  • Symbian S60 3rd Edition

Unzip distribution On setup.exe right click "Run as Administrator". Needs patches to cl_bapi.pm to bypasss errors from the CSL Toolchain as described above for GCCE.MK or old patch below. See patch below to allow GCCE to compile in Carbide.c++ 1.2

Exe Path C:\Symbian\9.1\S60_3rd_MR\Epoc32\Release\Winscw\Udeb\Epoc.exe

If you have RealTek High Definition Audio drivers carry out action in Windows Vista Drivers problem section.


*Symbian S60 3rd Edition Feature Pack 2 Beta Unzip distribution On setup.exe right click "Run as Administrator". Needs patches to cl_bapi.pm to bypasss errors from the CSL Toolchain as described below. See patch above or old patch below to allow GCCE to compile in Carbide.c++ 1.2

If you have RealTek High Definition Audio drivers carry out action in Windows Vista Drivers problem section.

The emulator works on FP2 beta and for this reason the is a patched version of cl_bapi.pm below. Feature Pack 2 give significant new features


Carbide.ui S60 Theme Edition 3.1

Load and works successfully built the zebra theme.


Java (tm) Mobile products

Install "Sun Java Runtime for Vista" ! not 1.5, but version 6.01 from Sun Java(tm) Runtime. Selected Windows online installation. This appears to load version 6 and later on reboot version 6.01 was loaded via update. This is also called version 1.6.01 further updates are downloaded when ready.

  • Series 40 5th Edition SDK

The Series 40 5th Edition SDK is the reference implementation SDK for the Series 40 Platform 5th Edition.

The install program of SDK has problems but the products work. The version 1.6 runtime is not recognized. Click continue from error and ok. The next error is Operating system not recognized. Click continue from error and ok. Finally some sort of command window open just close this. To load into Netbeans, from File Menu,Java Platform Manager,Open window wider and select "Add Platform". Select directory "C:\Nokia\Devices" and select the "Series 40 Platform 5th Edition" click ok when platform has been added. In the project select the Series 40 Platform 5th Edition, build and debug or run.


  • Netbeans 5.1 and Netbeans Mobile 5.1

These products provide the Nokia chosen method of Development now Carbide.J has been retired. The products need the Vista version of runtime.



  • Sun(r) Wireless Toolkit 2.5 (known as CLDC (tm) 2.5)

Install "Sun Java Runtime for Vista" ! not 1.5, but version 6.01 from Sun Java(tm) Runtime. Selected Windows online installation. This appears to load version 6 and later on reboot version 6.01 was loaded via update. This is also called version 1.6.01 further updates are downloaded when ready.

Now runtime install for Vista is complete download version jre1.5.0_12 or higher runtime from Sun Java(tm) Runtime and select to download and click "run" to install. This is believed to link to the Vista version and allow the toolkit to run.

When installing the toolkit the version Sun Runtime jre1.5.0_15is found and install using this toolkit. On install completion copy the shortcut for the KToolbar from the Vista Start bar to the desktop right click the shortcut select properties and tick the box "Run as Administrator" using "Windows XP Service Pack 2", click "ok", then start the KToolbar by double clicking the shortcut.

Successful compilation of the "MobileMediaApi" and running this example, during the running The program zayit.exe is network connection, it is blocked by a firewall, usually Windows firewall, simply add it to the list of allowed program to use the network. If you have a "corporate" firewall you could have a problem.


Eclipse Ganymede

Eclipse Ganymede is the latest version supports many functions, one of which is configurable support for many development environments, one example is to configure for WidSet SDK support using the Eclipse GUI instead of the command line.


Nokia Mobile Internet Toolkit (NMT 4.1)

Login in as Administrator. Make sure "Sun Java Runtime for Vista" ! and version 1.5.12or higher, from Sun Java(tm) Runtime are installed. Select Windows online installation. This appears to load version 6 and later on reboot version 6.01 was loaded via update. This is also called version 1.6.01 further updates are downloaded when ready.

On Vista the patch that comes with this kit is not needed as problems solved by loading 1.5.12 runtime. The main use for NMIT 4.1 kit is for OMA DRM 1.0, Digital Rights Management. There is an article on setup How to protect WRT widgets with OMA DRM 1.0


WidSets SDK

As of 1 June 2009 Nokia is closing down WidSets accounts and therefore development The WidSets SDK works when using the SunRuntime jre1.5.0_15. The Archived:WidSets Scripting Language which is similar to JavaME(tm) used in mobile phones allows creation of small applications without the need for Java Certificates. There is an Archived:Introduction to developing WidSets widgets and the SDK is command line and automatically uploads WidSet widgets ready for publishing.


Nokia Series 40 Theme Studio 2.2

Use Extract files option and run setup.exe from the command shell window Using Right click "Run as Administrator" on the Command shell shortcut. This avoids Vista Aero errors Load and works successfully.


Mobile products useful in development

  • Microsoft XML Notepad 2007 for Vista

This product will allow the examination of XML files (.xml) for debug as formatted blocks and is a new version for working with Vista. Entity can be added, edited and deleted. This is so much better than using notepad.

XML Notepad 2007


Python

Python 2.5.1 has been tested and works on Windows Vista Ultimate. Install python-2.5.1.msi as you normally would on XP, and you can use both command line and IDLE modes.

PySymbian 1.9.7 (PythonForS60_1.9.7_Setup.exe) has been tested and works on Windows Vista Ultimate.


PHP V5

The PHP 5.2.8 can be needed for Nokia Ovi services to use Ovi uploader To install select the path "C:\PHP\" for installation do NOT take default in "Program Files". Open up options and select Script version "php-win.exe" as well as "php.exe". In the "extras" options, select "PHP Manual" for MS style help file. Click "next" and check the box "Don't set up web server", unless you have a personal web server listed. Click "next" to start the install. When finished open command window select the path "C:\PHP\". type "php -inf" to inspect the program settings




Products which DO NOT work with Windows Vista (tm)

CSL Arm Toolchain

This program is the major cause of many of the problems for GCCE development kits for Carbide.c++ version 1.1

There is no update so solution is to change some files the S60 3rd Ed SDK as

in another article Patch for Windows Vista


Carbide.c++ version 1.1

Carbide.c++ v1.1 is not Vista compatible and GCCE fails outputting compilation errors. Use Carbide.c++ v1.2 instead.


Carbide.J 1.5 Java retired

Earlier in 2007 Nokia decided that other free tools are available and Carbide J is retired.

The product is now available in the Forum software archive Carbide 1.5 Archive

This WILL NOT make Carbide 1.5 work with Vista and other tools like Netbeans 5.1 will work with Vista without problem.

Status: Will not install under Vista in any circumstances. This is is a retired product and will freeze and 'hang' whilst trying to integrate with any products under Windows Vista(tm)in the uninstall section. The installer program fails not the products.

  • Update 13th October 2008

The installer appear to works on Vista making a short-cut and in properties Selecting "Windows 2000". Now right click the short-cut, and "Run As Administrator". This takes a long time to install, because of the emulator calls Carbide.J


These patches are old and consider using the patch [h[#Using_the_Vista_patch_S60_5th_Edition_v0.90_on_previous_versions|above]]

S60 3rd Edition FP1

The compilation for GCCE can be patched as described above to make compiler run. The emulator crashes before completing startup. The solution is to use Windows XP or use 3rd Edition Feature Pack 2 (FP2).


S60 3rd Edition SDK patch file cl_bpabi.pm

This file is extracted to the correct path and replaces cl_bpabi.pm

C:\Symbian\9.1\S60_3rd\Epoc32\tools\cl_bpabi.pm the C:\CSL ToolChain\ must exist. If you use other drives use the SUBST command. This will only work where all the kits are installed on the C: in most cases this will not ba a problem as Vista always has a c: root drive.

This will only get you through the compile stage. For specifics on getting the link stage working go here: Windows Vista.


Media:s60 3rd ed vista patch.zip


S60 3rd Edition Feature Pack 1 (FP1) SDK patch file cl_bpabi.pm

This file is extracted to the correct path and replaces cl_bpabi.pm Set to root of drive and extract to path

C:\Symbian\9.2\S60_3rd\Epoc32\tools\cl_bpabi.pm the C:\CSL ToolChain\ must exist. If you use other drives use the SUBST command. This will only work where all the kits are installed on the C: in most cases this will not ba a problem as Vista always has a c: root drive.

This will only get you through the compile stage. For specifics on getting the link stage working go here: Windows Vista.

NOTE: These same changes work for UIQ 3.1 release SDK as well.


Media:s60 3rd ed FP1 vista patch.zip


S60 3rd Edition Feature Pack 2 Beta (FP2 Beta) SDK patch file cl_bpabi.pm

This file is extracted to the correct path and replaces cl_bpabi.pm Set to root of drive and extract to path

C:\Symbian\9.3\S60_3rd_FP2_Beta\epoc32\tools\cl_bpabi.pm the C:\CSL ToolChain\ must exist. If you use other drives use the SUBST command. This will only work where all the kits are installed on the C: in most cases this will not be a problem as Vista always has a c: root drive.

This will compile link and sign a SIS file.

For specifics on getting the compile link without patches and debugging Windows Vista.

Note that this patch file contains a bug. It won't accept multiple STATICLIBRARY. I've got an updated file but don't know how to post it. See: http://www.developer.nokia.com/Community/Discussion/showthread.php?104023-carbide-bug-multiple-static-library-prob..


Media:cl bpabi s603rdFP2.zip

Related Links

This page was last modified on 1 August 2013, at 08:32.
273 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×