×
Namespaces

Variants
Actions
(Difference between revisions)

Utility to quickly check Qt and Qt Mobility versions

From Nokia Developer Wiki
Jump to: navigation, search
croozeus (Talk | contribs)
m (Tested on)
somnathbanik (Talk | contribs)
m
Line 1: Line 1:
 
[[Category:Qt]][[Category:Qt Mobility]]
 
[[Category:Qt]][[Category:Qt Mobility]]
 +
 
 
==Introduction==
 
==Introduction==
 +
{{Abstract| This article shows how to find out the current version of [[Qt]], [http://doc.qt.nokia.com/qtmobility-1.2/ Qt Mobility] and also [http://www.opengl.org/ OpenGL].}}
  
This small utility application can be used to find out the current versions of Qt and Qt Mobility and also OpenGL.
 
  
 
==Prerequisities==
 
==Prerequisities==
  
You would need the Qt SDK installed to compile the utility example code.
+
You would need the [[Qt SDK]] installed to compile the utility example code.
  
 
==Example code==
 
==Example code==

Revision as of 16:08, 14 June 2011


Contents

Introduction

This article shows how to find out the current version of Qt, Qt Mobility and also OpenGL.


Prerequisities

You would need the Qt SDK installed to compile the utility example code.

Example code

#include <QtGui>
#include <QtOpenGL>
#include <qmobilityglobal.h>
 
const char* openglVersion()
{
const char *OpenGLVersion;
switch (QGLFormat::openGLVersionFlags()) {
case QGLFormat::OpenGL_Version_1_1:
OpenGLVersion = "OpenGL 1.1";
break;
case QGLFormat::OpenGL_Version_1_2:
OpenGLVersion = "OpenGL 1.2";
break;
case QGLFormat::OpenGL_Version_1_3:
OpenGLVersion = "OpenGL 1.3";
break;
case QGLFormat::OpenGL_Version_1_4:
OpenGLVersion = "OpenGL 1.4";
break;
case QGLFormat::OpenGL_Version_1_5:
OpenGLVersion = "OpenGL 1.5";
break;
case QGLFormat::OpenGL_Version_2_0:
OpenGLVersion = "OpenGL 2.0";
break;
case QGLFormat::OpenGL_Version_2_1:
OpenGLVersion = "OpenGL 2.1";
break;
case QGLFormat::OpenGL_Version_3_0:
OpenGLVersion = "OpenGL 3.0";
break;
case QGLFormat::OpenGL_ES_CommonLite_Version_1_0:
OpenGLVersion = "OpenGL ES Common Lite 1.0";
break;
case QGLFormat::OpenGL_ES_Common_Version_1_0:
OpenGLVersion = "OpenGL ES Common Lite 1.0";
break;
case QGLFormat::OpenGL_ES_CommonLite_Version_1_1:
OpenGLVersion = "OpenGL ES Common Lite 1.1";
break;
case QGLFormat::OpenGL_ES_Common_Version_1_1:
OpenGLVersion = "OpenGL ES Common Lite 1.1";
break;
case QGLFormat::OpenGL_ES_Version_2_0:
OpenGLVersion = "OpenGL ES 2.0";
break;
case QGLFormat::OpenGL_Version_None:
default:
OpenGLVersion = "No Open GL";
break;
}
return OpenGLVersion;
}
 
int main(int argc, char *argv[])
{
QApplication a(argc, argv);
 
QFont font("Nokia Sans", 32);
QLabel label;
label.setFont(font);
label.setText(QString("%1Qt: %2<br>Runtime Qt: %3<br>Qt Mobility: %4<br>OpenGL: %5")
.arg(qstrcmp(QT_VERSION_STR, qVersion()) ? "<h1 style=\"color: red\">Mismatch detected!</h1>" : "")
.arg(QT_VERSION_STR)
.arg(qVersion())
.arg(QTM_VERSION_STR)
.arg(openglVersion()));
label.setAlignment(Qt::AlignCenter);
label.show();
 
return a.exec();
}


You should compile this example for yourself using the SDK for your target device.

Tested on

  • Emulator
  • Nokia N900
90 page views in the last 30 days.
×